Everything I own is now on my phone :(

flur

macrumors 68020
Original poster
Nov 12, 2012
2,191
914
This morning I updated my iPhone, selected to use iCloud music library (because Apple said I had to use it to use Apple Music), and everything was fine. Then I got home and updated iTunes. Now every song I've ever bought (about 50gb of music on my hard drive) is appearing on my phone. It doesn't appear that they're all downloaded to it, because the option to "make available offline" appears next to songs that I did not previously have on the phone, but I they're all showing in My Music, even though I have the setting to only show music stored on the phone turned on.

Is anyone else seeing this? Is there any way to fix it?
 

maxsix

Suspended
Jun 28, 2015
3,102
3,683
Western Hemisphere
I've learned that for my preferences and to save time, never touch any new update/upgrade until it's been out for awhile. Read the reports here and then decide if it offers a benefit. Newer is not always better.

Hopefully someone will come along with an answer for you.
 

MentalFloss

macrumors 65816
Mar 14, 2012
1,012
769
This morning I updated my iPhone, selected to use iCloud music library (because Apple said I had to use it to use Apple Music), and everything was fine. Then I got home and updated iTunes. Now every song I've ever bought (about 50gb of music on my hard drive) is appearing on my phone. It doesn't appear that they're all downloaded to it, because the option to "make available offline" appears next to songs that I did not previously have on the phone, but I they're all showing in My Music, even though I have the setting to only show music stored on the phone turned on.

Is anyone else seeing this? Is there any way to fix it?
Are you sure you have it set to only show local music? When you are in the "My Music" -> "Library" view, there is a little arrow next to e.g. "Artists". If you tap that arrow, a menu appears where you can select to see or not to see music that is only available offline. That should clean up your library and you will only see locally available music.

If that doesn't fix it, then it's a bug. Works fine for me. You'll have to hold out for 8.4.1 then. :(
 

flur

macrumors 68020
Original poster
Nov 12, 2012
2,191
914
Are you sure you have it set to only show local music? When you are in the "My Music" -> "Library" view, there is a little arrow next to e.g. "Artists". If you tap that arrow, a menu appears where you can select to see or not to see music that is only available offline. That should clean up your library and you will only see locally available music.

If that doesn't fix it, then it's a bug. Works fine for me. You'll have to hold out for 8.4.1 then. :(
Absolutely positive. I've been toggling that switch on and off all day for various reasons. It works fine for showing or not showing Apple Music, but it shows everything in my Mac iTunes whether it's on my phone or not. The only way I found to fix it is to remove my Mac from iCloud music. Obviously that's not ideal, but it's what I'm doing for now.