Everything is lagging/delay - Please help! :/

Discussion in 'iMac' started by mainmike, Jan 16, 2014.

  1. mainmike, Jan 16, 2014
    Last edited: Jan 16, 2014

    mainmike macrumors newbie

    Joined:
    Jul 24, 2012
    #1
    Im on my imac: http://screencloud.net/v/uKZU
    Recently updated my memory and its been working good after that.

    But now suddenly i experience delay/lagging when i write. Not all the time, but still pretty often. I type something, and then it takes 3-4 seconds before it appears on screen. Same goes with using backspace, and scrolling with the track pad also generate delay (recently switched battery on trackpad also).

    Ive tried rebooting the system, and im not using any more heavy software or something compared to before this started.

    Anyone knows what its about?

    Thanks in advanced.
     
  2. tgrays macrumors member

    Joined:
    Apr 21, 2013
    #2
    Are you experiencing these delays when writing, regardless of which application you're typing on? On Finder too?

    Just wondering if it may be an issue with an application or if this typing lag is happening everywhere. Also, is your keyboard wireless or wired?

    Off the top of my head, provided your memory upgrade isn't the cause, I'd probably do some testing to make sure it isn't application or system related, as well as plug in a wired keyboard (if yours is wireless) just to see if the problem is present under other circumstances too.

    I'm only speaking from my own experience in the past where I've had the issue on a couple of applications (and after some updates, it went away). And my sister experienced something similar once, which turned out to be a bluetooth problem of some sort.

    I'm sure someone else more knowledgeable will chime in soon though, who can tell you more and whether your memory upgrade could be the culprit or not.
     
  3. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #3
    To OP :

    First, test in another account, and let us know how it works there.
     
  4. mainmike thread starter macrumors newbie

    Joined:
    Jul 24, 2012
    #4
    Good point about the application. Tested in mail and and safari, no delay. Seem like it a firefox issue.

    What could be wrong with FF?

    Thanks.
     
  5. tgrays macrumors member

    Joined:
    Apr 21, 2013
    #5
    It could be a number of things, from an add-on, flash, a script hanging, a website you're viewing, etc.

    First thing I'd do is update your Firefox to the latest version (including all the add-ons) if that hasn't been done yet. It could be a bug in any of those. Oh and update your Flash too. Also take a look at the Activity Monitor when the problem acts up to see there are any unusual usage/activity.

    If everything is up to date and the problem persists, you can try restarting Firefox in safe mode (Help --> Restart with Add-ons Disabled...). If the problem goes away after this, chances are it's one of your add-ons causing the problem. In that case, you'd have to go in and test your add-ons one by one (unless you've recently installed something new, then chances are it's that one). Sometimes, it's not necessarily one add-on or another but a conflict between two, etc.
     
  6. mainmike thread starter macrumors newbie

    Joined:
    Jul 24, 2012
    #6
    Ive pretty fed up with the whole FF concept, so i switched to chrome, gonna use this for a while and take it from there.

    Btw, another issue i experienced right after upgrading to Maveric is that when i try to mark something on screen (tapping pad/mouse, holding and moving up or down) like when you mark parts of text content to copy, then it suddenly stop/freeze like it reach a limit, then i have to move a little back and forth to make it go again. This goes across all browsers.

    Any clue?
     

Share This Page