Resolved Everything Quits Unexpectedly

Discussion in 'Mac Basics and Help' started by holland909, Oct 29, 2016.

  1. holland909 macrumors newbie

    Joined:
    Oct 19, 2014
    #1
    Hello,

    I am sorry if this has been addressed before, but I kept finding the topic from previous OSes before Sierra.

    With that being said, I came home this afternoon and powered on my iMac like normal. I tried opening up Safari, but as soon as I clicked on it, the app put up the normal "Program Quit Unexpectedly" error. So I went onto Firefox and found a solution that helped me fix that. Now I tried opening up Mail, and mail started giving me the same "Program Quit Unexpectedly" error. Starting to get frustrated, I opened up the App Store to see if there were possible updates and I do have four that need to be done, but I still get the "Program Quit Unexpectedly" error when trying to Install the updates.

    So with no other idea that might be able to fix this, I decided to download the Sierra update again from the Apple website. When I try to get the install to go, it gives me "Program Quit Unexpectedly" error.

    I am out of ideas and I am hoping that perhaps someone with more technical experience could help me figure out what could be the problem. I couldn't see any malware from some YouTube videos I watched, but maybe there is something new out there that someone might be aware of?

    Please help,

    Thank you!
     
  2. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #2
    Do you have another user account? If not, are you able to create one?

    So if the problem goes away on a second account, move your files to that account. Once you're sure all is well, you can delete the misbehaving account and move on. You might not ever find the reason this happened and waste all kinds of time in the process. But, if this suggestion doesn't work, you have to keep digging.
     
  3. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #3
    Reboot into recovery mode by holding down Command-R while booting.
    Go into disk utility.
    In the left window click on the line that shows the manufacturer of your hard drive. Click on Repair Disk or First Aid.
    Assuming that completes with no errors, click on the next line down in the left window which is likely Macintosh HD unless you have renamed your boot volume. Again, click on Repair Disk or First Aid.

    Let us know if that completes and shows the disk as Okay or Repaired.

    If it does, reboot and see if that has fixed your problem.
     
  4. holland909 thread starter macrumors newbie

    Joined:
    Oct 19, 2014
    #4
    I spoke with Apple Chat Support last night about the issue. It was an Operating System error and I just had to simply reinstall Sierra. Everything works again. Thank you!
     

Share This Page