Everything works EXCEPT Instant Hotspot

Discussion in 'OS X Yosemite (10.10)' started by LincolnsiPod, Nov 22, 2014.

  1. LincolnsiPod macrumors 6502

    Joined:
    Nov 20, 2009
    #1
    Using a mid-2014 rMBP, and trying to use instant hotspot with either an iPhone 6 Plus or iPad Air 2. Both show up under the Personal Hotspot section of my WiFi menu with battery usage, signal strength and other details, but when I click on them, it refuses to connect. The old way (by switching hotspot on and connecting manually) still works though. I can also use instant hotspot to tether the iPad to the iPhone and vice versa, but both cannot cannot connect to the MBP.

    Using 10.10.1 for MBP, and 8.1.1 for both iPhone/iPad. I tried everything: resets, power cycling, changing the names of devices, all the tricks that were mentioned in previous threads to no avail. Handoff works, Continuity works, but not this? I don't get it. It's definitely specific to Yosemite too since I can use instant hotspot between my iPhone and iPad devices.

    Has anyone experienced similar and tried something that worked that may not have been mentioned before in other threads? I'm at my wits end.
     
  2. LincolnsiPod thread starter macrumors 6502

    Joined:
    Nov 20, 2009
    #2
    Update:

    I finally connected with Instant Hotspot for the first time ever. :eek:

    Here was my workflow in case it helps anyone else: I logged out of iCloud for all three devices and logged back in. This still didn't work however. After I did this, though, I switched Hotspot ON in my settings for the iPhone. I then clicked on instant hotspot on my MBP to connect, and after a few seconds it finally connected. I then disconnected, switched Hotspot to OFF in my settings, and tried again. Success!

    Even though Hotspot settings should be OFF when using instant hotspot, for some reason, initially turning it on for the first connection seemed to activate instant hotspot for me. Once I did that I could switch it off, and continue using instant hotspot. I did the same thing for my iPad and it worked there as well. So at least in my case, it was necessary to turn hotspot in my settings ON and connect via instant hotspot for the first time before I could switch it off again.

    Note: I had tried turning hotspot on and connecting manually, then trying "instant hotspot" with no result. Apparently, for this to work I needed to switch it on BUT instead of connecting manually, connect via instant hotspot instead. It's the only thing I did differently this time, so maybe that's what worked.

    So to sum up: log in and out of iCloud for all devices, reset/restart all devices, turn hotspot in your settings ON, then connect via "Instant Hotspot" (NOT manually). Once connection is verified, disconnect, then turn off Hotspot in your settings, then go back and try connecting via Instant Hotspot again.
     

Share This Page