Evil Netgear DGN2000 wifi/airport trouble

Discussion in 'Mac Basics and Help' started by kenloen, Nov 12, 2009.

  1. kenloen macrumors newbie

    Joined:
    Nov 1, 2009
    Location:
    Surrey
    #1
    Hiya,

    I am new to the world of Mac having just bought a used MBP, splashing out I also bought a new wi-fi router to match, a Netgear DGN2000 to replace a DGN384.
    OK now the problem is I see can the DGN2000, but I cannot get a link to the outside world - Misery. I also have a XP machine and an Ubuntu server, both hard wired connected and these are working fine, using DHCP and both have outside internet, it seems its purely the wifi connection. The airport connection connects to my router no problem but it just doesnt access anything beyond that - I have no internet. I have also tried a ethernet cable which also appears to look fine under system preferences/network, the ISP is connected, but again no internet. The weird thing is I can connect to 2 local wifi connections no problem and can see the internet through their links..

    I have searched, the firewall is set to accept all incoming. But now I m at a loss, can anyone help..

    much appreciated,

    rgds Jason
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Do you have any other computers with wireless capabilities? It would be helpful to know if the problem is with your computer or your router.

    Go into  -> System Preferences -> Network. What does the text next to AirPort say? From there, go to AirPort -> Configure -> TCP/IP. Type the IP address listed beside "Router" on that page into the address bar in Safari. Do you see the router configuration page?
     
  3. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #3
    Do what BlueRevolution said to figure out if you're really connected or it's just saying you are. (That it doesn't work with Ethernet, either, sounds suspiciously like the computer, not the router, though--Ethernet almost ALWAYS works, particularly if two other computers hardwired to it work.)

    One added thing, turn off the OSX firewall completely while you're troubleshooting. It's not usually a source of problems with simple connectivity, but no sense in having an additional factor in the mix. (Besides, if it's behind a router and a private network, you theoretically don't need a firewall other than to protect from unauthorized users connected wirelessly to your router.)
     
  4. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #4
    ... which shouldn't happen if you've configured your network security properly.
     
  5. kenloen thread starter macrumors newbie

    Joined:
    Nov 1, 2009
    Location:
    Surrey
    #5
    via wifi the ip is 192.168.0.2 which is the next available. Wired I have 192.168.0.20 (XP) and 192.168.0.100 (Ubuntu Server). if I connect the MBP wired I get a weird 168.192.0.162 which is nothing close. even if I fix the ip (wired) I get no joy..

    how can I disable firewall completely??

    the reason I am questioning the Router as well as the MBP is because I can connect via 2 neighbours wifi without any problem at all, I search, find and connect.. wouldnt really be a problem if they stayed connected 24/7 ;-) but they dont....
     
  6. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #6
    So you can't connect to the router config page of your network?
     
  7. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #7
    First off, let's stick to just a wired connection, since the less variables the better, and you know other computers are working that way.

    Turning off the firewall is System Prefs --> Security --> Firewall --> Allow all incoming connections. You may already have it off.


    Now, the fact that you're not pulling a DHCP address even when connected wired at least narrows down what's going on a little. If you go to Network, select Ethernet in the list, click Advanced, and click Renew DHCP Lease, what happens? (This page should also tell you if it's a self-assigned IP address, which I'm guessing is the case.)

    Additional question: Have you configured your router to do any kind of MAC filtering and/or port fowarding? If you have, and your Mac isn't in the list, that would be the symptom.
     
  8. kenloen thread starter macrumors newbie

    Joined:
    Nov 1, 2009
    Location:
    Surrey
    #8
    OK firewall off.
    if I connect wired and renew DHCP it gives me the weird ip address not remotely connected, can I cannot access router gateway. if I connect wireless I can connect to the gateway.

    I am now thinking to possibly restrict the router, being a 2000n maybe I should try a G connectivity? I am not sure of the MBP connectivity
     
  9. kenloen thread starter macrumors newbie

    Joined:
    Nov 1, 2009
    Location:
    Surrey
    #9
    OK, this has been resolved - might also help others with internet issues.

    Although I have a static ip and fixed DNS ip's on the router itself, the MBP picks up these details but still wasnt resolving addresses. The solution was to add another ip to the DNS servers list. (Networks/Advanced/DNS). with the help of Netgear tech support we found I could ping 4.2.2.2, so added this (4.2.2.2) to the list of O2 DNS servers and it works a treat.

    hope this might help others getting stuck, its been a frustrating problem.


    rgds Jason
     

Share This Page