Excel 2008 formula bar problem

Discussion in 'Mac Apps and Mac App Store' started by Ian S, Mar 19, 2008.

  1. Ian S macrumors newbie

    Mar 19, 2008
    The left edge of my excel formula bar is not showing-almost as if it was pushed off the left side of the desktop (see picture). Unfortunately, the only part of the formula bar that allows it to move is now hidden, so I can no longer move the formula bar. I have tried switching the formula bar on and of in "View" and also tried re-loading excel, but it is stuck.

    Does anybody know how to reset the formula bar position?

    Thanks in advance.

    Ian S.

    Attached Files:

  2. wrldwzrd89 macrumors G5


    Jun 6, 2003
    Solon, OH
    Try moving Excel's preference file to your desktop then relaunching Excel. It's probably in /Users/username/Library/Preferences and called com.microsoft.Excel.plist.
  3. nemex macrumors regular


    Nov 14, 2007
    Gee! this is bad, have you tried ctrl-clicking in the Formula bar? I just did and a Reset toolbar option appears there (in my case appears greyed out but my formula bar is in the correct position)

    Hope this helps!
  4. Ian S thread starter macrumors newbie

    Mar 19, 2008
    The control clicking idea did not work, but deleting the excel plist file worked perfectly. Thanks wrldwzrd89
  5. dduff617 macrumors newbie

    Sep 19, 2006
    i had the same problem. i was able to fix it. but it has come back again a few more times since. there's definitely something screwy here. shouldn't be this much work to straighten out basic toolbars.
  6. bigchiefmunkey macrumors newbie

    Apr 20, 2009
    Hey, I launched excel this morning and my titlebar was all sorts of jacked up - it was like 10px wide and scrolled any selected cell's text downwards one character wide. wow, annoying.

    I reset this plist file and it now works like a champ. Registered to just thank thank you *:)
  7. tthornyone macrumors newbie

    Jan 6, 2004
    Orange, CA
    Formula Bar Alignment Fix

    I'm using Excel 12..

    I was unable to fix with others mentioned here, until I found the preference "Excel Toolbars (12)"

    I moved Excel's Toolbar preference file to my desktop (could have trashed it) then relaunched Excel. Mine was in /Users/username/Library/Preferences/Microsoft/Office 2008 and called "Excel Toolbars (12)".

    I hope this helps others! Good Macin' to you!!
  8. Vincent63 macrumors newbie

    Jan 7, 2013
    You saved my life ! Works fine with me

    You saved my life ! Works fine with me
  9. johnscriven macrumors newbie


    Jan 6, 2016
    Even 12 years on, this information is a pleasure to read when Excel still contains bugs.

Share This Page