Excel for Mac 2011 - Command-c

Discussion in 'OS X Yosemite (10.10)' started by Paul753, Nov 12, 2014.

  1. Paul753 macrumors newbie

    Joined:
    Nov 12, 2014
    #1
    I recently updated to Yosemite on a late 2009 iMac and some important keyboard shortcuts in Excel for Mac 2011 have ceased to function. In particular, the Copy command shortcut now shows as Command-c instead of Command-C and does not seem to function as the copy command.

    Right-click copy command and Menu-Edit, Copy function normally but the shortcut does not.

    Also, the Paste command, Command-V has been demoted to Command-v and does not function either.

    These are essential keyboard shortcuts to Excel users; anybody know what happened to them ? Yosemite ?

    Paul753
     
  2. chabig macrumors 68040

    Joined:
    Sep 6, 2002
    #2
    It's something peculiar about your system. Yosemite didn't change Excel. Check Tools > Customize keyboard to see and reset the default settings.
     
  3. Paul753 thread starter macrumors newbie

    Joined:
    Nov 12, 2014
    #4
    Checked the Keyboard Customizer

    Chabig,

    Thanks for responding. As suggested, I checked the Tools, Customize Keyboard area for Edit, Copy and found in the Current Keys section:
    Control+Ins
    Control+c
    F3
    Control+Help
    Command+Help
    Command+Ins
    Command+c
    (Testing these "other" shortcuts results in only Control+c working successfully)

    I have not changed any of these myself. I note that the keyboard shortcut hint on the Menu - Edit, Copy used to show the shortcut as <Command symbol> C, not the lower cased "c" that currently shows.

    I attempted to add another short cut with "c" again to determine if it created an upper or lower cased "c", but the Remove and Add buttons are greyed out.

    Perhaps noteworthy, Word in the Office for Mac 2011 suite exhibits no problem with the Command+C shortcut, only in Excel. All updates to Office have been applied.

    Suspecting the dysfunction might be localized to the current worksheet, I opened a new worksheet but it also fails to function.

    Another peculiarity, and there may be others, is that copying and pasting column widths via Paste Special, column widths doesn't function either.

    Curious and curiouser
    Paul753
     
  4. Paul753 thread starter macrumors newbie

    Joined:
    Nov 12, 2014
    #5
    This worked

    A great set of "answers" !

    The one that seems to work, without fouling the edit/paste menu systems was:

    Do this: system preferences -> Keyboard -> Input Sources -> uncheck Automatically Switch to a Document's Input Source. Then RESTART Excel.

    "Automatically Switch..." was already unchecked when I looked, so I checked it, closed the dialogue, reopened System Preferences, Keyboard, Input Sources and unchecked the check-box. Restarted Excel and voila.

    There were other methods suggested, but this one didn't effect other menus in Excel.

    Thanks to all,
    Paul753
     

Share This Page