Excel Link with %20 in path name fails

whbunn

macrumors member
Original poster
May 29, 2009
69
17
I have several sheets linked to a sheet "Quotes" which contains recent stock prices. On one sheet when opened says it cannot find linked sheet. I noticed a peculiarity on the problem sheet which has %20 in the path for the enclosing folder.

I have broken link, changed file names and locations and this one file when establishing link and %20 in path, and error to link on next opeening.
 

Attachments

chabig

macrumors 604
Sep 6, 2002
6,728
3,949
The broken URL isn't a valid URL...not because of the %20 but because it doesn't begin at the file system root. You need to change it to either one of these

~/Dropbox/Financials/Vanguard Funds
/Users/whbunn/Dropbox/Financials/Vanguard Funds

Note: In paths, ~/ is short for your home. It's the same as /Users/whbunn/
 
  • Like
Reactions: BasicGreatGuy

whbunn

macrumors member
Original poster
May 29, 2009
69
17
The broken URL isn't a valid URL...not because of the %20 but because it doesn't begin at the file system root. You need to change it to either one of these

~/Dropbox/Financials/Vanguard Funds
/Users/whbunn/Dropbox/Financials/Vanguard Funds

Note: In paths, ~/ is short for your home. It's the same as /Users/whbunn/

Thanks

I didn't notice that it didn't start at root level. How can I fix that?

Bill
 

chabig

macrumors 604
Sep 6, 2002
6,728
3,949
Thanks

I didn't notice that it didn't start at root level. How can I fix that?

Bill
I don't know exactly since I don't know how to create links inside Excel. But I can guess it would be one of two ways:

1. Type the correct pathname if you have a chance, or
2. Use a dialog box to get to the right place and the software should take of it for you.

I suspect you typed the link that's already there, or else I don't know how it might have that error. There must be a way to edit it.
 

whbunn

macrumors member
Original poster
May 29, 2009
69
17
It is strange because I use Excel Links feature to establish link I do not type in path. I have broken link and reestablished it via excel dialog box selecting file. Excel adds the correct path. The next time the file using the link is opened Excel has dropped "/Users" from the path
 

chabig

macrumors 604
Sep 6, 2002
6,728
3,949
That is strange. I do have Excel, so I will play with the linking feature a little bit. Let’s figure it out.

Instead of linking spreadsheets, could you make them separate sheets in the same document? Then you wouldn’t have this linking problem to deal with at all.
 

whbunn

macrumors member
Original poster
May 29, 2009
69
17
The sheet I am linking to contains about 15 stock quotes that are used by several other workbooks. So the option of putting it as a sheet in this one workbook is not practical.

This issue of dropping “/Users”. Only occurs with one workbook. I have renamed it, deleted and recreated it, moved it, you name it I tried it. Then when I establish link then close workbook and reope; the path has been truncated.

Bill
 

whbunn

macrumors member
Original poster
May 29, 2009
69
17
That is strange. I do have Excel, so I will play with the linking feature a little bit. Let’s figure it out.

Instead of linking spreadsheets, could you make them separate sheets in the same document? Then you wouldn’t have this linking problem to deal with at all.

chabig

Thanks for your suggestions. I have renamed/moved files, folders etc. every associated file/folder.


Links are working as expected now.

Bill
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.