Excel selecting multiple cells; too annoying!

Discussion in 'Windows, Linux & Others on the Mac' started by Dal123, Oct 27, 2013.

  1. Dal123 macrumors 6502a

    Dal123

    Joined:
    Oct 23, 2008
    Location:
    England
    #1
    Majority of times I click on Excel it selects 3-4 cells. I have tried:
    1. Turning mouse double-click speed down;
    2. ClickLock is turned off
    3. Sticky Keys are not turned on.

    This is actually becoming too annoying and it is dramatically effecting my productivity. Grateful of any suggestions.
     
  2. Dal123 thread starter macrumors 6502a

    Dal123

    Joined:
    Oct 23, 2008
    Location:
    England
    #2
    Anyone got any ideas, I'm getting nothing done as unable to select cells :(.

    Very grateful of any guidance?
     

Share This Page