Excel - Spreadsheet calculates slowly

Discussion in 'Mac Apps and Mac App Store' started by DamnGreg, Sep 1, 2008.

  1. DamnGreg macrumors newbie

    Joined:
    Sep 1, 2008
    #1
    Recently bought an imac and transfered eveything over from windows. The only problem I have is an excel spreadsheet that takes forever to calculate on every entry.
    I have several small spreadsheets that run fine but the big one I use calculates so slow is unusable. Runs fine on windows.
    Anyone have any ideas?
     
  2. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #2
    Which version of Excel are you running? 2004 or 2008? If it's 2004 you need to upgrade: it's running in emulation on any recent Mac. If it's 2008 then complain to Microsoft: it's their software!
     
  3. DamnGreg thread starter macrumors newbie

    Joined:
    Sep 1, 2008
    #3
    I'm running Excel 2004 on Windows and 2008 on Mac. I opened my spreadsheet with a trial version of excel 2007 on windows that also runs slow. Must be a problem wit an upgrade from 04 to 08. I'll contact microsoft. Thanks
     
  4. nsbio macrumors 6502a

    nsbio

    Joined:
    Aug 8, 2006
    Location:
    NC
    #4
    This behavior is normal, unfortunately. Windows Excel 2007 is slower than 2003. Mac Excel 2008 is way slower than Excel 2004.

    FWIW, Mac Excel 2004 is slower than Windows Excel 2003. Conclusion: Mac Excel 2008 is too slow to be useable for large spreadsheets. Office is one area where Windows versions are superior to Mac's, at least speedwise.
     
  5. DamnGreg thread starter macrumors newbie

    Joined:
    Sep 1, 2008
    #5

    That may be true,but this seems extraordinarily slow.Its just simple math. Gonna try to come up wth a solution on Friday.Redo some formulas if I have to.I've used this spreadsheet with Mac Excel 2004 and had absolutely no problems.
     
  6. ewilson6 macrumors 6502

    Joined:
    Nov 30, 2006
    #6
    try going to system preferences and opening up the shared folder.

    uncheck the windows sharing box.

    this speeded up excel quite a bit on my system.
     

Share This Page