Excellent DL speed but high latency on O2

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ventmore, Aug 17, 2008.

  1. ventmore macrumors 6502a

    Joined:
    Jul 13, 2008
    #1
    Using testmyiphone.com, my DL speed consistently hits 1.3Mbps, and I've seen it go as high as 1.9, but the latency seems really high at 700-800ms.

    Using http://i.dslr.net/tinyspeedtest.html to check my latency, I get figures of around 300-400ms, with at least one really high figure nearly every time......sometimes as high as 6000ms.

    Is this just the nature of mobile broadband?

    Cheers
    Neil
     
  2. ventmore thread starter macrumors 6502a

    Joined:
    Jul 13, 2008
    #2
    Could someone (preferably on o2) please try the 3G test at http://i.dslr.net/tinyspeedtest.html and report back......after 15 or so runs, I'm getting latency as high as 8000ms which seems absolutely ridiculous.

    On a sidenote, I tried my iPhone sim in my windows mobile phone (on the suggestion of o2) which gives slightly more network info in that it shows a different icon for 3G and HSDPA. It seems that I'm flicking regularly between 3G and HSDPA......could this be the cause of the latency issue?
     
  3. ventmore thread starter macrumors 6502a

    Joined:
    Jul 13, 2008
    #3
    It seems that the high latency almost always only happens on the first, and maybe second ping after the connection is idle...after that, I get 300-350ms.

    Basically...if I browse to the page and run the test immediately, it seems to work quite well, but if I browse to the page then leave it a while before running the test, I get the high latency problem on the initial pings. Similarly, if I browse to the page, then press the home button, the reopen safari and run the test, I get high latency initially...sometimes as high as 11000ms for the first ping. I get the same result using GPRS, 3G, and Wifi, so I wonder if the connection goes into some sort of power saving mode, and that's why th initial connection takes longer.

    I did go into the local CPW today to try their demo models, and they seemed to work a little better, but they're running FW 2.0.0, and I'm on 2.0.1, so it's not really a fair test.
     

Share This Page