Excessive CPU on iMac

Discussion in 'iMac' started by roadkill401, Sep 23, 2016.

  1. roadkill401 macrumors 6502

    roadkill401

    Joined:
    Jan 11, 2015
    #1
    I will admit that i don't know a whole load about mac osx and the ins and outs of the mac environment

    Yesterday i thought i would try out macos sierra on a virtual machine to see how it works and figure out if my apps that i use support it. i didn't quite get that far. I got the sierra downloaded and then did a force quit on the install app that started up after the download completed. then from that point onwards my iMac fan when into hyperdrive.

    I took a look at Activity Monitor and there are 4 apps that seem to be chewing up cpu cycles and that is likely what is heating up the cpu and driving the fan.

    UserEventAgent 82.5%
    launchd 81.4%
    cfprefsd 36.1%
    mds_stores 29.4%

    i called apple support as i have applecare and they thought it was becuase of timemachine and it running. but if i turn off timemachine the apps dont stop and the the fan is still in hyperdrive. i can shut down the imac and wait 2-3 minutes and the cpu does cool down a bit. when i power up it's fine for about 3-9 minutes and then those procesesses kick back in and the fan goes back to full bore

    i called back apple care again and the sr support agent (who came across as an arrogant A!) insisted that it was an external device that is plugged into the iMac. Apart from my keyboard and some lightning connectors the only other thing that i have plugge in is my Lacie 3tb drive via thunderbot. I tried ejecting it and the processes calm down and the fan will slow. Remount the Lacie, and the problem comes back.

    He suggested that it's the drive that is failing. Is this a common thing? would re-formatting the drive fix it? i have gone into recovery console and did a fix on the Lacie and it says it can't find anything wrong. I don't want to be working with a red herring and replace a drive that was not faulty. Apple seems to take the approach of wipe everything and re-install rather that diagnose the problem. the first call was convinced it was timemachine. what would be the best steps to figure out why this fan is just ramping up into sonic jet mode?
     
  2. rawweb, Sep 23, 2016
    Last edited: Sep 23, 2016

    rawweb macrumors 6502a

    rawweb

    Joined:
    Aug 7, 2015
    #2
    I've got lots of ideas for you, but let's try some basic things first. Disconnect everything but essential components only (keyboard, mouse) and download istat: https://bjango.com/mac/istatmenus/. This will help you monitor CPU temps, memory temps, fans etc. Get a reading of your computer hanging out doing nothing important.

    My Late 2015 iMac likes to idle (light web work like typing this) around 98F. Fan at about 1200 RPM. Get a reading of what is going on.

    Screen-Shot-2016-09-23-at-11.05.40-PM.png

    I suppose it's possible your computer was trying to back up to TM or was indexing itself. Also, what version of OS are you running? Don't run the VM for the first temp reading, it's possible something with that was causing the computer to overdrive. What model computer is it? 27" 5k?

    Worse comes to worse, if you have AppleCare, you can always haul it into the Apple store.
     
  3. roadkill401 thread starter macrumors 6502

    roadkill401

    Joined:
    Jan 11, 2015
    #3
    I did figure it out this morning. After a whole load of steps. I backed up my Lacie drive to a new external drive called Lacie-Backup using my CCC. With the lacie unmounted, the problem did go away. I ran with that for a day and CPU issue didn't re-occur.

    I re-mounted the Lacie, with Activity monitor turned on and watched but the CPU didn't increase until I accessed the Finder App, then the problem cam back. Then it dawned on me to look at the apps associated with the 'open with' and found that they were all messed up. I ran ONyX and did a rebuild of the LaunchServices and the problem is now fixed.

    Guess the Apple Sr. Support Genius wasn't so genius after all. Got it half right in the issue was sort of being caused by the Lacie drive, but not in the reasoning he gave (drive failure), but a messup in OS-X pointing to a Fusion VM that did not exist. Don't know how this happened but all is working fine now.
     
  4. havokalien macrumors 6502a

    havokalien

    Joined:
    Apr 27, 2006
    Location:
    Kelso, Wa
    #4
    well third party stuff will be beyond any real help from apple. They dont have anything really to do with 3rd party external hardware. I would call Lacie and say your having an issue with MacOS and their dirve and see what kind of update they can do.

    Its the same reason Apple had all those issues with graphic drivers, then just gave the support back to nvidia at the time.

    That was usually the reason Mac just worked is they made the software and the hardware and it would just work. Add other devices and you were on your own. i.e. CD rom toolkit, Hard Disk toolkit, conflict catcher just to name a few. If you wanted more the repair or use was on you.
     
  5. roadkill401 thread starter macrumors 6502

    roadkill401

    Joined:
    Jan 11, 2015
    #5
    The problem ended up having nothing to do with the Lacie other than it happened to be an external drive that was plugged into my iMac at the time. The issue was to do with Apple Finder and it messed up something to do with default apps that run when a particular file extension is found in finder. For some reason it changed the location path of an app to my Lacie drive from where it was to where it was not. This in turn made the 4 listed background apps go into excessive scrub mode and eat up CPU cycles that caused the iMac to heat up and turn the fans on to high.

    All from trying to download a version of Sierra.
     
  6. Feenician macrumors 68040

    Feenician

    Joined:
    Jun 13, 2016
    #6
    Nice troubleshooting and good bit of info if others find them themselves in the same situation, OP.
     
  7. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #7
    Good work, I've had this happen to me once in a blue moon, though its so incredibly rare, that I did not think of that when I saw your thread.
     

Share This Page