Exchange Account Failing on iPhone 4 (4.0.1)

Discussion in 'iPhone' started by lavrishevo, Jul 17, 2010.

  1. lavrishevo macrumors 68000

    lavrishevo

    Joined:
    Jan 9, 2007
    Location:
    NJ
    #1
    Just getting my wife's iPhone 4 setup and updated to 4.0.1. Her Microsoft Exchange account works correctly on her old 3G (3.1.3) and on her iPad (3.2.1) but gives this error when trying to retrieve mail: "The connection to the server failed" on the iPhone 4. We have re-entered the correct information many times and also tried the account on my iPhone 4 and it gives the exact same error.

    Again, the account seems to setup and verify fine under settings > mail > etc.. but once we try to retrieve the mail it fails with the server error. Any ideas?
     
  2. nerk69 macrumors newbie

    Joined:
    Jul 9, 2010
    #2
    I would suggest deleting and recreating the exchange email. I currently have 7 iPhones connected to exchange and we are not having any problems. When every I have seen the "The connection to the server failed" has been because the phone did not have a working data connection. I would toggle airplane mode and try again. No problems.

    Also, have you tried a force quit of the mail.app?
     
  3. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #3
    Try completeling removing the account and restarting.

    Didn't Apple said they fixed Exchange bugs in iOS 4.0.1?
     
  4. Wicked1 macrumors 68040

    Wicked1

    Joined:
    Apr 13, 2009
    Location:
    New Jersey
    #4
    I am not having any trouble and yes Apple did release the Bar fix and Exchange bug fix in 4.0.1 however I have not installed the update either and no trouble here. Do what the other ppl said it should work also download the patch.
     
  5. Blackforge macrumors 6502

    Joined:
    Mar 8, 2008
    #5
    This firmware only includes the timeout "fix". There are some other issues that haven't been fixed yet.

    That said, do you know what version of Exchange she is connecting to? Exchange 2010 has the ability to only allow approved devices to sync, so this version may not be allowed yet.
     
  6. digbyp macrumors regular

    Joined:
    Jul 10, 2008
    #6
    I hope this helps some!

    I have a 3G iPhone. Under v3.1.3, had no problems with anything (apart from battery life, which is common). After upgrading to iOS 4.0, I was experiencing a lot of crashes which resulted in a lot of auto re-starts or manual re-starts because the screen just froze. I also noticed that the syncing between Exchange account that happenned previously was not the same with iOS4.0. That is, although email would arrive on iPhone pretty much immediately, if I deleted email from desktop computer, it did not delete from the iPhone straight away, like it used to.

    Being a developer, I now have installed iOS4.1 beta. The crashes have now stopped, but email deletions still do not happen immediately on the iPhone like they did before.

    I knew that it was email that had caused the crashes, as in my 'crash logs' there were numerous entries daily, which compared to the 3-4 crashes that happenned daily.

    Does not really help to sort any ones issues, but just detailing my experiences. One other thing, v4.01 seemed to make the iPhone notceably slower peforming basic finctions. v4.1 seems to have improved that, but not to where the v3.1.3 was
     
  7. lavrishevo thread starter macrumors 68000

    lavrishevo

    Joined:
    Jan 9, 2007
    Location:
    NJ
    #7
    Thanks for all the suggestions. We have deleted the account multiple times and restarted the phone. It is not due to lack of a data connection as the 3 other mail accounts are working fine. Also, since it exhibits the same behavior on my iPhone 4 it is not her particular phone.

    The only thing I can think of is it must be either a bug on the phone side or, as mentioned, this particular exchange server denying access for some reason.

    The difficult part is getting help through the universities 'IT department.' Worse then calling India for tech support...
     
  8. jameskk macrumors regular

    Joined:
    Sep 22, 2003
    Location:
    South Carolina
    #8

    Does it work on 3G? I had the same problem on wifi but it worked on 3G. 4.0.1 fixed the problem for me.
     
  9. lavrishevo thread starter macrumors 68000

    lavrishevo

    Joined:
    Jan 9, 2007
    Location:
    NJ
    #9
    Same error both on wifi and 3G. I spoke with Apple today and eventually talked within senior technician. According to them, it is related the specific exchange server I am trying to connect to and the new iOS 4. It it was working great before why go and change it with the new OS...? Now have to go to the university and deal with them. Thanks for all the suggestions.
     
  10. alangrehan macrumors regular

    Joined:
    Jan 15, 2008
    #10
    This is strange....

    for me since updating to 4.01 my exchange account works fine on 3G and Wifi except when I'm using the Wifi at work where the exchange server is!

    Can't for the life of me figure out why on Wifi there it won't work but all other Wifi is ok....

    Any ideas?
     
  11. tm954 macrumors newbie

    Joined:
    Sep 13, 2010
    #11
    Try this one...

    I've had the same issues with some iPhones not finding a server to connect to Microsoft Exchange 2010. I have better than 40 iPhones connecting, both 4g and 3gs, but every once in awhile there is a problem device- or account.

    Try this solution, if you find yourself in the same situation. Open the Active directory properties for the user account that is unable to connect to email with the iPhone. Under security settings, go to Advanced and make sure that the checkbox for Allow Inheritable permissions from the parent to propagate to this object and all child objects is checked :eek: .

    Once I did that one two accounts that were giving me issues, they both started to work. Before this fix was applied, I would be able to verify the account, but the error 'unable to contact server' would appear. I could configure a different Exchange account on the iPhone without a problem, but only certain accounts (those with the missing checkbox) exhibited a problem.
     

    Attached Files:

  12. Gjeepguy macrumors regular

    Joined:
    May 19, 2010
    #12
    for my exchange account to work properly SSL needs to be turned off.
     
  13. Syk macrumors 6502a

    Joined:
    Jun 20, 2010
    #13
    I know this was asked months ago but it's probably the way your network is setup. Your exchange server has a public and private IP.

    Your firewall probably isn't allowing your private IP to connect to the public side. If you changed your exchange acct on your phone at work to the private ip and got on the wifi at work it probably would work until you used your 3G or other wifi connection

    When you're on wifi someplace else you're not on your companys network so it connects
     

Share This Page