Exchange Admins - iPhone, ActiveSync, and MinHeartbeatInterval lower than 300

Discussion in 'iPhone Tips, Help and Troubleshooting' started by matthiasgoodman, Jul 18, 2008.

  1. matthiasgoodman macrumors member

    matthiasgoodman

    Joined:
    Jul 13, 2005
    Location:
    Chandler, AZ
    #1
    I am a the Exchange admin for a medium sized business (150 seats). We have half a dozen Windows Mobile phones that work correctly with Exchange ActiveSync (Exchange 2003). They frequently get heartbeat intervals of 1800 or higher. I have found that iPhones won't even register for AUTD (ActiveSync) if the MinHeartbeatInterval registry key on the server is set to anything higher (sorry I miss-typed it in the title) than 300. What I mean is that the iPhone won't create the AutdState.xml file in the NON_IPM_SUBTREE (
    Code:
    https://exchangeserver/exchange/username/NON_IPM_SUBTREE/Microsoft-Server-ActiveSync/iPhone/Applxxxxxxxxxx/
    ) folder. This means that the device will check for new data on manual syncs only but will not receive any push data since it is not even trying to keep a connection open. Has anyone else seen anything like this? Am I doing something wrong.
     
  2. Slip Jigs macrumors 6502a

    Joined:
    Feb 18, 2008
    #2
    I'm not an Exchange expert or admin by any means - but what is the default setting? It works fine on our server and I'm sure whatever setting it's on is the default as we never had any reason to set or change this.
     
  3. matthiasgoodman thread starter macrumors member

    matthiasgoodman

    Joined:
    Jul 13, 2005
    Location:
    Chandler, AZ
    #4
    you are right, it works fine with the default setting (60 seconds) but it seems that the iPhone never increases its heartbeat (although it claims a heartbeat of 300); I can see it on the server pinging every 60 seconds. I think this is why everyone is saying that the iPhone battery runs out too quickly with ActiveSync. In a proper implementation the iPhone should start out trying for a 5 minute (300 seconds) heartbeat and slowly increase it until it found the networks limit (which, in our case is about 59 minutes unless AT&T is timing out our connections). If you watch your IIS logs you will probably see the iPhone checking every 60 seconds. That is what I have seen and it would explain the battery drain. As I said, most of our other devices are getting between 20 and 45 minutes with some going up to 59 minutes (the hard limit impossed by Exchange).

    What does your AutdState.xml file look like? What does it say for heartbeat interval? Thanks for your help and contributions.
     
  4. Mindflux macrumors 68000

    Mindflux

    Joined:
    Oct 20, 2007
    Location:
    Austin
    #5
    I don't get an Audtstate file for my iPhone either in Exchange 2k3 SP2. Hrmm. I seem to be getting push data though. I have fetch disabled all together on my iPhone and just shot myself an email to my work address and my iPhone made the new mail tone 15 seconds later.


    By the way you have your Min/Max in DWORD type Decimal right? If they are in Hexidecimal it changes them to values outside of the 1-59 minute range and when you restart IIS you get an alert about it.
     
  5. matthiasgoodman thread starter macrumors member

    matthiasgoodman

    Joined:
    Jul 13, 2005
    Location:
    Chandler, AZ
    #6
    I get the file if I set the minheartbeatinterval to a value less than or equal to 300 (5 minutes). If not I never get it.

    Are you using IAS or just a plain IIS server?

    Edit: we are on a IIS server with no IAS. Yes, they are in decimal.
     
  6. Mindflux macrumors 68000

    Mindflux

    Joined:
    Oct 20, 2007
    Location:
    Austin
    #7
    IIS. Also Exchange 2003 w/ SP2. :)

    When I try and open the audtstate file it tells me it does not exist.
     
  7. matthiasgoodman thread starter macrumors member

    matthiasgoodman

    Joined:
    Jul 13, 2005
    Location:
    Chandler, AZ
    #8
    Well, it kinda works now

    I still have the problem where push won't work if the MinHeartbeatInterval is set to a value higher than 300 but push does work now.

    I have also noticed that ever since I called AT&T and asked my IP address hasn't changed. They said there were no changes they needed to make but it seems they must have changed something, either specifically for me or globally. I am getting much better battery life now too.

    Thanks.
     
  8. Mindflux macrumors 68000

    Mindflux

    Joined:
    Oct 20, 2007
    Location:
    Austin
    #9
    Did you get anywhere with this. I'm still missing an Autd-State.xml. I can't even open the NON_IPM_SUBTREE 'web folder' to see it's contents.
     
  9. matthiasgoodman thread starter macrumors member

    matthiasgoodman

    Joined:
    Jul 13, 2005
    Location:
    Chandler, AZ
    #10
    I haven't found the solution to the not working if the MinHeartbeatInterval is set to higher than 300 but it does seem to be working better since I called AT&T. I think they have fixed something on there side (maybe they had a connection time out that was set too low). I still say the iPhone is too sensitive or not taking the average over long enough of a time. There is a KB article at microsoft.com about how the heartbeat interval is determined by the phone and the iPhone seems to let the number grow for a while and then drop back down to 300.

    About your not finding the NON_IMP_SUBTREE folder, if you use forms based authentication you can't load it as a webfolder. You can get to the folder by going to logging into you Outlook Web Access and adding username/NON_IPM_SUBTREE (substitute your username for username to the address in the address bar. I hope this helps. Let me know.
     
  10. Mindflux macrumors 68000

    Mindflux

    Joined:
    Oct 20, 2007
    Location:
    Austin
    #11
    That did it. There's nothing to be seen there, the folder is empty.
     
  11. matthiasgoodman thread starter macrumors member

    matthiasgoodman

    Joined:
    Jul 13, 2005
    Location:
    Chandler, AZ
    #12
    You don't have a Microsoft-Server-ActiveSync folder with an iPhone subfolder containing an APPLxxxxxxxxx subfolder with xxxxxxxxx being your iPhone serial number?

    Well, I don't know if there will be very much interesting information in there anyways, other than being able to determine your current HBI if you want to know it.
     
  12. Mindflux macrumors 68000

    Mindflux

    Joined:
    Oct 20, 2007
    Location:
    Austin
    #13
    Ah, there it is. OWA folder view is kinda wonky. According to the AudtState.xml my heartbeat interval is 600 seconds. FWIW my Minheartbeat is set at 60s.
     
  13. mfriesen macrumors newbie

    Joined:
    Aug 25, 2010
    #14
    fixed issue with iphone push battery drain

    I spent hours on this issue with no success, and just now finally got it fixed from the exchange side, so figured I should share and save someone else the headache.
    description of problem:
    all of a sudden users of iPhone that were getting 10+ hours of battery get 3 hours of battery life.
    exchange email push is enabled on iphone
    exchange 2003 server was running AVG enterprise (this may be the root problem, associated with a MS patch to Exchange virusscan)

    things that did NOT work for me but saw suggested and may work elsewhere:
    modify heartbeat min/max settings for activesync
    increase idle-disconnect time for https connection on firewall
    remove settings from iphone and reconfigure
    reset phone
    remove account associations to active-sync on exchange server and recreate
    clean up calendar appointments in outlook
    checked for mailbox corruption

    fix that worked (on exchange server, no ISA):
    1.) check the below mentioned registry and found its value set to 0 (disabled).
    HKLM\System\CurrentControlSet\Services\MsExchangeIS\VirusScan\
    BackGround Scanning and ProActive Scanning.
    2.) set the values to 1 for both.
    3.) gracefully dismounted the Mailbox and Public Folder stores and restarted Microsoft Exchange Information Store Services.

    Marc Friesen
     

Share This Page