Exchange - doesn't get all Inbox items...just a week's worth

Discussion in 'iPhone Tips, Help and Troubleshooting' started by btownguy, Jun 20, 2009.

  1. btownguy macrumors 6502

    Joined:
    Jun 18, 2009
    #1
    So this is my first iPhone after having been a WM user for a couple of years. I'm liking the phone, but I'm having one problem. I setup a new mail account and used Exchange (for my work address) and told it to sync email/calendar/contacts. I think contacts and calendar are working correctly. However, the email is only getting about a week's worth. I told it in settings to get 200 days worth, but this is not happening. Is there some simple setting somewhere I'm missing? I turned off all push and fetch settings and want to sync manually.
     
  2. kyleaa macrumors regular

    Joined:
    Jun 20, 2006
    #2
    Settings -> Mail, Contacts, Calendars -> [Exchange Account Name] -> Mail Days to Sync -> No Limit
     
  3. btownguy thread starter macrumors 6502

    Joined:
    Jun 18, 2009
    #3
    That did it. Thanks!!!
     

Share This Page