Exchange email issues since 2.2

Discussion in 'iPhone Tips, Help and Troubleshooting' started by jwflutterby, Nov 24, 2008.

  1. jwflutterby macrumors regular

    Joined:
    Jul 9, 2008
    #1
    I have been having a lot of issues with my Exchange email account since I upgraded to 2.2... Syncing seems to take a lot longer and moving messages to folders or the trash only works about 10% of the time... I have a .me and a Gmail account that seem to be fine, it is just my work email that is acting up. I tried deleting the account and re-adding it but I am still having problems...

    My main reason for having my work email on my iPhone is that I get a lot system status updates and reports overnight and I like to dump everything out to the appropriate folders while I am getting ready for work so when I get to work I only have things I have to respond to left in my inbox... Since 2.2 though, I read the message move it to the folder go on to the next message, move that one, etc. until I'm through about 10 messages then I start getting popups saying "could not move message to folder X" for every message I just moved and they all come right back into my inbox... Sometime after about 3 tries it stays, sometimes message will not stay in the folder no matter how many times I try to move it... This is ridiculous! I never had this problem before 2.2 and it is making my work email account on the iPhone unusable :mad:
     
  2. MDMac macrumors regular

    MDMac

    Joined:
    Dec 2, 2006
    Location:
    Sacramento, CA
    #2
    This same thing was happening with my mail2web exchange account so I may be of some help. What I did was I deleted all my e-mail accounts off my iPhone then I did a full backup + sync. I then added them back onto my iPhone and voila! Every account would poll in an exceptional amount of time. Moving e-mails to folders etc. began working just like it did before 2.2. Hope this helps. :)
     
  3. jwflutterby thread starter macrumors regular

    Joined:
    Jul 9, 2008
    #3
    I tried that already... A couple messages moved to folders but then I was right back to the "message could not be moved" garbage... I hate to do it but I might have to back down to 2.1 because my work email is more important than street view or the other new Google stuff...
     
  4. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #4
    I've got two EDU mail accounts and I've turned on the IMAP option for both of them. Not sure if that's an option for you, but IMAP has been a godsend...:(
     
  5. FearlessFreep macrumors 6502a

    Joined:
    Jul 15, 2008
    Location:
    Northern Virginia, USA
    #5
    Not saying it will fix your problems, but I was having major issues last week with my Exchange. Removing the account and then re-adding did not help. What I ended up doing was removing the account and then doing 'Reset All Settings' on my phone. Yes, it's a pain and you'll have to re-enter in a lot of preferences and re-arrange your icons, but it cleared the problem right up for me.
     
  6. Wolf103FM macrumors regular

    Joined:
    Apr 29, 2006
    Location:
    Huntsville AL
    #6
    I noticed this happening with my mail2web account as well on 2.2, BUT, it is also happening to my other m2w account on my 2.1 touch

    update: 11/27
    my mail2web appears to be working as it should again, but we'll see if it lasts this time
     

Share This Page