Exchange not working on iPhone 6 Plus

Discussion in 'iPhone Tips, Help and Troubleshooting' started by shrimptooth, Sep 19, 2014.

  1. shrimptooth macrumors newbie

    Joined:
    Sep 19, 2014
    #1
    Anyone else having trouble getting their Exchange accounts up and running after restoring their phone to an iPhone 6+?
     
  2. jediuia macrumors regular

    Joined:
    Sep 12, 2014
    #2
    Yes same problem, I deleted and re entered. It takes it it fine, but nothing downloading. I hope someone knows how to fix. Need my work email!
     
  3. rbf1138 macrumors 6502

    Joined:
    Dec 22, 2007
    #3
    Same problem here. Doing gmail push using the Exchange and it wont populate my Mail at all.
     
  4. jediuia macrumors regular

    Joined:
    Sep 12, 2014
    #4
    Well I figured out my issue...

    My companies exchange only allows up to 10 devices activated on exchange, and my iPhone 6+ was the 11th. Just had to remove an old phone through the exchange web app and it worked like a charm.

    You could be having something similar going on.
     
  5. rbf1138 macrumors 6502

    Joined:
    Dec 22, 2007
    #5
    I'm trying to use gmail with exchange so definitely nothing to do with work accounts or anything like that.
     
  6. Zamrod macrumors newbie

    Joined:
    Sep 19, 2014
    #6
    I'm having the same problem setting up GMail using their exchange server on my iphone 6. It doesn't appear to be a bug in iOS 8 as my iphone 5 can still access the exchange server properly. Although, my iphone 5 was previously set up and I haven't readded the account in iOS 8, so the bug might just be with first time setup.

    What is happening is that I am adding the exchange account, putting in Google's server information: m.google.com and my username and password. It verifies they are all correct, and puts check marks beside everything. However, then it doesn't appear to download any of the mailbox information. There are 0 e-mails found and it doesn't detect the folders. So, it doesn't show the deleted items, sent items, etc.

    If I set the same mailbox up as a gmail account, it works normally but with no push notifications.

    The one other odd thing I've noticed while setting it up as an Exchange server is that when I go into the settings for the Exchange account, where it says "Automatic Reply" at the bottom, it just says "Loading..."

    Also, if I go into Fetch New Data and select the Exchange server in the list, it is set to push, however at the bottom where it lists "Pushed Mailbooxes" it only lists Inbox and I can't put a check mark beside it. When I do the same thing on my iPhone 5, it shows Inbox, Sent, Trash, All Mail, Spam, Starred, Notes, Personal, Receipts, Travel, Work.

    There's definitely weird going on in terms of using Gmail's Exchange server(and I assume other Exchange servers as well) using the iPhone 6.
     
  7. chanc macrumors member

    chanc

    Joined:
    Oct 2, 2012
    Location:
    San Jose, CA
    #7
    Thanks for this ! I'm having the exact same issue.
     
  8. Zamrod macrumors newbie

    Joined:
    Sep 19, 2014
    #8
    Actually, after doing some digging, I found this thread: https://discussions.apple.com/thread/5119928

    It appears that Google have specifically turned off their exchange server to any new accounts. It only works on devices that had already checked their e-mail at least once before February of this year unless you have a paid account.

    Now I know. That's why my old phone works.

    The work around appears to be to set up your Gmail account as a normal Gmail account on the phone and then install the Gmail app which will get push notifications on new e-mail. Then just open up your e-mail every time the app tells you that you have new e-mail and fetch the e-mail.

    Either that or upgrade to a paid gmail account.
     
  9. Greg-Ae macrumors newbie

    Joined:
    Sep 19, 2014
    #9
    All, Google stopped supporting new devices sometime last year for free users. See link:

    http://appleinsider.com/articles/13/03/25/googles-push-gmail-changes-surprise-new-iphone-buyers-apple-store-reps
     
  10. Fwny macrumors newbie

    Joined:
    Sep 20, 2014
    #10
    While this is true, this isn't necessarily the issue being experienced here. I have a Google Apps account and am experiencing the exact same issue as everyone else in this thread. It is driving me nuts I can't get my work email account on my shiny new iPhone 6. What is odd is that I didn't have this problem in the iOS 8 beta versions.
     
  11. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #11
    Paid Google Apps accounts are supposed to work set up as Exchange. Some people in this thread do not fall into that category.

    If there's an issue in iOS 8 or on the iPhone 6 with setting up paid Google Apps accounts as Exchange there's not much info out there on it as yet...but it looks like something is amiss.
     
  12. WeeBitObsessed macrumors newbie

    Joined:
    Sep 20, 2014
    #12
    Fixed It For Me

    I have an Corporate (non-gmail) exchange server..

    This is Odd... but reseting my phone and turning off Wifi (IE using LTE) only worked, not all of my exchange mails, folders, contacts, Notes ETC are downloading..

    Not yet sure why using Wifi doesn't work, and not yet sure what happens when i turn Wifi back on.

    But, Exchange is working with ONLY LTE turned on.
     
  13. mattcube64 macrumors 65816

    mattcube64

    Joined:
    May 21, 2006
    Location:
    Missouri
    #13
    I can't get my corporate exchange account (neither email or calendar) to work, which is a disaster for me. I don't know what to do... But my phone is darn near useless without those things. Guess I'll carry around my iPad with me tomorrow... :-/ Hope someone comes along with a fix...
     
  14. macrophage1 macrumors newbie

    Joined:
    Sep 21, 2014
    #14
    Same problem

    I had no problems with the corporate exchange server with the iOS8 upgrade on Wednesday but can not validate the account with my iphone 6 (Friday). This is important to work emails and calendar.

    Any suggestions are welcome.
     
  15. Drelldrell macrumors newbie

    Joined:
    Sep 17, 2014
    #15
    This worked for me also. Specifically, I deleted network settings. After reboot and a few minutes, emails and calendar started populating. Added my wifi back and it continues to work.

    Sure this is going piss off a few thousand corporate iphone 6 owners.
     
  16. macrophage1 macrumors newbie

    Joined:
    Sep 21, 2014
    #16
    re: same problem

    The issue was with the corporate exchange server which is limited to two devices. Once the old iPhone was removed from my devices the new one started working.
     
  17. Yakuzahi macrumors member

    Yakuzahi

    Joined:
    Oct 10, 2010
    #17
    I don't have an iPhone 6, but I see that when I load iCloud backup to my iPhone 5, the exchange does work on IOS 8. However, when I set it up as a new phone, it doesn't.

    Apple told me to check with Google before they will open a high level ticket for this issue, but as you know, it's easier to contact God than Google.
     
  18. SundayDuffer macrumors 6502

    SundayDuffer

    Joined:
    Jun 25, 2011
  19. mgrangeiro macrumors newbie

    Joined:
    Sep 29, 2014
    #19
    don't know how to set up google corporate account as exchange

    Brian. Thanks for the info. I've set up a corporate account with Google, but don't know how to set up as Exchange. Any help is much appreciated.

    Thanks,
    Marco
     
  20. anoren macrumors newbie

    Joined:
    Jul 20, 2011
    #20
    I solved my problem. Kind of.

    I have the problem that my iPhone 6 doesn't download all the mails in the "sent" folder. The last months were missing.
    And when i tried to trash mails from the sent folder it said that it couldn't move the mail to the trash folder.

    I inactivated the account on the iphone.
    Set the limit for how long time period to download to the phone to one month.
    Activated the mail account.
    And now it downloaded the last months of mail.

    Changed the time limit ot infinite.
    And now it downloaded the mails up ot the point there it choked last time. And I miss a few months of mails.

    In this case it seams that the iPhone chokes on a particular mail. And we have had this problem before with iPhones here at work.

    I switched to my Mac and deleted a few mails (on the date where the phone chokes) and it was one mail in particular that was a large illustrator vector map. (a complete city). And when I had deleted this it seams that my phone now has downloaded all mails again.

    /Andreas
     
  21. CTM macrumors newbie

    Joined:
    Sep 30, 2014
    #21
    Google Apps Users ... Read This

    If you use a Free Google Apps account and are using Google Sync (Google's Active Sync / Exchange) for mail, you will not be able to setup your mail account on a new device. That is why it still works on your old device but will not work on your new device. They are not activating the any new devices on their Google Sync service for Free Google Apps accounts.

    According to Google's help article on Google Sync...
    https://support.google.com/a/answer/135937?hl=en&ref_topic=1220873

    "Starting Jan. 30, 2013, only Google Apps for Work, Government, and Education customers can set up new devices with Google Sync.

    Google Sync uses Microsoft® Exchange ActiveSync® to let your users synchronize their Google Apps mail, contacts, and calendars to their mobile devices. They can also set up alerts (sound or vibration) for incoming messages and upcoming meetings.

    Google Sync is enabled by default on Google Apps domains. Google Apps for Work, Education, and Government domains can enforce security policies on Google Sync devices. To learn more, see Google Apps Mobile Management."
     
  22. Gokio macrumors newbie

    Joined:
    Oct 2, 2014
    #22
    Guys I beleive it's being caused by that little "Trust this network" pop up when you first join a new wifi. If you try alternative networks when you setup the account it works fine and syncs.

    That's why resetting the network settings works as a fix.
     
  23. cuculu macrumors newbie

    Joined:
    Aug 9, 2011
    #23
    sharedkey?

    I'm having the same issue with the exchange setup for m.google.com
    I know that google does not support this anymore, but i was wondering if i could trick my new iPhone 6 to behave like the old 4s which i have in my custody and it works like a charm.

    I did a restore on my 6 from the backup of the 4s, in the hopes that it will also copy all the necessary files to overcome this exchange issue fault. But it does not work, it acts like as if I set it up for the first time.

    But i was wondering, what makes the 4S work still work on Google exchange? There might be a file inside the phone that maybe we could copy across to the new device and make exchance work again .. like a sharedkey of some sort .. a plist file that we could modify ...

    Maybe somebody here knows more, and would like to investigate this.
    For example: where are all the preference files for the mail app kept locally on the device? Does anyone know?

    How is Google performing it's checks to allow or deny access to this obsolete service?
     
  24. floatingspirit macrumors 6502

    Joined:
    Oct 13, 2001
    Location:
    Seattle, WA
    #24
    This has worked for many:

    1. I left my non-functioning exchange account on the phone.
    2. i turned off wifi
    3. went to Settings/General/Reset/Reset Network Settings
    4. phone rebooted and my Exchange account started working (on LTE)

    I'll turn wifi on later...

    See: https://discussions.apple.com/thread/6544887?searchText=iphone 6 not working with exchange settings
     
  25. rooter2010 macrumors newbie

    Joined:
    Nov 4, 2014
    #25
    gmail not working on iphone 6

    I got it to work!

    I went into my gmail account on my computer and under settings I turned on IMAP. Then set up email under the Google option in phone under settings>mail. It worked perfectly!

    Here is the link
    https://support.google.com/mail/answer/77702
     

Share This Page