Exclamation point wackiness

Discussion in 'iPod' started by SteelWheel, Jun 4, 2008.

  1. SteelWheel macrumors member

    Apr 16, 2008
    I know there have been some threads about these issues, but none of them seem to address my specific problem. I'm currently using a Windows formatted iPod classic (160 GB), with my iTunes library on an external hard drive. I use my iPod almost exclusively for podcasts. Sometime within the past few days, I started to see my library become riddled with those silly exclamation points. But the content in question was still happily sitting on my iPod. When I sync it, I get the message that says the file "foo" will not be copied (along with 100+ others) because the content could not be found. Quitting iTunes and restarting generally clears this up. But whenever I go to sync the iPod again, the exclamation points return.

    I even went through all the exclamation point-ed material, by hand:mad:, and attempted to restore the link by trying to start playing each podcast, have iTunes tell me that the file could not be found, and going through the process of "finding" it (right in the same folder with other episodes of the same podcast which somehow did NOT become exclamation point-ed). Looked like it was a brute force solution which should have worked--but it didn't. I still have the same situation.

    Admittedly, this is not totally tragic, since I appear to still have the content in question. Nevertheless, it's an annoying situation to deal with--besides, if I ever do start losing content, I may not be aware of it at first, since I will have been conditioned to ignore the error messages and exclamation points.

    Any ideas here? I was actually looking forward to migrating my iTunes library and iPod to Mac format on my new MBP, but now I've been sidetracked into this nightmare--I have to solve this issue first (and be sure that all my content is safe and accessible) before I can tackle that project. Thanks.
  2. zaphodga macrumors newbie

    Jun 6, 2008
    I'm having the same problem with mine. I'm running Windows with a Windows-formatted iPod. I'm running version with verision 1.3 on my iPod. It's maddening because it only happens when I'm syncing. I have to go out and download it again manually and put in in my itunes library from the file system. Arrrrgggg!

  3. SteelWheel thread starter macrumors member

    Apr 16, 2008
    Nice to know that somebody else is having the same issues--your screenshots look just like the problems I'm encountering. My only theories on this: Either some kind of issue with RSS feeds being updated with iTMS being slow on the uptake, some other iTunes bug, or perhaps some recent XP update not playing well with iTunes.

    My latest off-the-wall concepts on "fixing" this problem: Two ways to go, both sort of the same idea. Use an app such as CopyTrans for Windows, and force my library to look like a clone of my iPod. Or, copy my iTunes library from my NTFS formatted HDD to an HFS formatted HDD, and plug that into my new Mac, essentially "starting over".

    Are there any true iTunes gurus on here, willing to help out and point us in the right direction? It would really be appreciated, thanks.
  4. SteelWheel thread starter macrumors member

    Apr 16, 2008
    Sorry for the bump, guys, but I have been hitting forums, both here and elsewhere looking for a solution for this exclamation point hell. To reiterate: Primary problem is that nearly all of my library is podcasts. I do have a few podcasts which steadfastly refuse to be downloaded from iTunes, although they are, AFICS, ready and available to be downloaded. I could deal with that alone I guess, but the more important problem is that whenever I hook up my iPod to be synced, iTunes suddenly scatters hundreds of these stupid exclamation points all over my library, and advises me that "foo", along with 100+ other files will not be synced since they can't be found. AFAICS, these files are still on the iPod, but iTunes is refusing to sync them. btw, quitting iTunes and restarting it generally clears most of the exclamation points (except some small number of individual podcasts here and there that just refuse to be downloaded).

    Solutions/kludges already attempted: I tried to just transfer the whole library to an HFS formatted drive (I'm currently on NTFS and XP, but right now in a process of migrating to OS X), hoping that maybe that would solve the problem--no dice (and Yes, I did it the right way, consolidating all the music, than changing the path names with a text editor, doing a find/replace to change them all in one go). About half my content was just lost.

    I have not yet attempted to use CopyTrans or CopyPod, to make my iTunes library look exactly like my iPod--my iTunes library is actually much larger than my iPod classic 160 GB, and I don't want to lose the material that's in the library, but not on the iPod.

    Another potential route to go was indirectly mentioned in the comments on this topic from lifehacker:


    Some people were suggesting variations of this idea:

    the trick is to corrupt ( not delete ) the binary database file.

    1) Copy over the files

    2) Currupt by opeinging the binary database in editor of your choise and adding a few spaces to the first few characters

    3) Open iTunes and watch it re-import your library.


    I would do something like this, copying over from one NTFS drive to another, if I was sure which file I'm supposed to corrupt.

    After this, I don't know what else to do. I would need the assistance of somebody who is an iPod/iTunes guru, who is also pretty good with both PC and (ultimately) OS X as well--the XP element of the situation kind of prevents me from seeking the help of the "Genius Bar". I really would like to get as much of my life away from XP as possible.

    If I could solve this situation, and get all my content over to iTunes on my MBP, without having lost anything, I would be running to get a new iPhone. Until this issue is resolved, I'm uncomfortable with adding any more complications to the matter, what with data being copied and re-copied back and forth to one external HDD or another, unsure as to what is going on where. If everything resided happily in Mac-land, I could get an iPhone with a clear conscience.

    If it helps, I might even be willing to offer a bit of a bounty to anyone who walks me through this nightmare.

    Again, TIA for any help.

Share This Page