Exclude iTunes Movies from Time Machine?

Discussion in 'Mac Apps and Mac App Store' started by dcains, Oct 16, 2012.

  1. dcains macrumors regular

    Joined:
    Mar 27, 2007
    #1
    Is there a way to exclude iTunes movies from Time Machine backups? The "Movies" folder is grayed-out in the "exclude these items from backups" feature under Time Machine options. I ask this question because I add TV shows and movies to iTunes really just for a short term, maybe a day or two, until I can watch them using AirPlay on my TV, and then they're deleted. For example, four 1-hour TV episodes equals about 20GB of mp4 files, and it's a waste of Time Capsule space to back them up.

    Is there a terminal command I might be able to enter to exclude the "Movies" folder? Thanks in advance.
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Just exclude ~/Music/iTunes/iTunes/Media/Movies within Time Machines options in the preference pane.
     
  3. dcains thread starter macrumors regular

    Joined:
    Mar 27, 2007
    #3
    That's exactly what I'm trying to do, and while I can see and select that folder, the "exclude" button is grayed-out.
     
  4. Dweez macrumors 65816

    Dweez

    Joined:
    Jun 13, 2011
    Location:
    Down by the river
    #4
    Have you "unlocked" your TM preferences?
     
  5. dcains thread starter macrumors regular

    Joined:
    Mar 27, 2007
    #5
    Of course. In fact, I can exclude individual movie files from the backups, but not the Movies folder as a whole. I need to exclude the entire folder because the file names are always changing.
     
  6. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #6
    Are you on Mountain Lion? My iTunes movies are at /Users/username/Music/iTunes/iTunes Music/Movies and I just checked and it allows me to exclude this from Time Machine. Are you an admin user?
     
  7. Dweez macrumors 65816

    Dweez

    Joined:
    Jun 13, 2011
    Location:
    Down by the river
    #7
    Which version of OSX are you running, and might you have a screen shot of the issue?
     
  8. dcains thread starter macrumors regular

    Joined:
    Mar 27, 2007
    #8
    Lion 10.7.5

    Perhaps this is a permissions issue? When I try to open the ~users/username/music folder in finder I get a message that I don't have permission to see its contents. I am the only user on this computer, AFAIK I have administrator privileges, and the folder permissions are set to "read and write" for both the "system" and "everyone". The "locked" check box in the "get info" frame is grayed-out and unchecked. The OS is Lion 10.7.5. Is there a way to change the folder settings so I can view its contents?
     
  9. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #9
    Yep.. this is definitely a permissions issue.

    Try this:

    1. Restart holding ⌘+R to boot into Lion Recovery, which will bring you to the Repair Utilities screen.

    2. Open Terminal from the Utilities menu.

    3. In Terminal, enter resetpassword to open the Reset Password utility.

    4. Choose your hard drive icon at the top, then choose your user from the drop-down menu below. Do not reset the password here.

    5. At the bottom of the window, under "Reset Home Directory Permissions and ACLs", click the "Reset" button. This may take awhile if you have a lot of files in your home folder.
     
  10. dcains thread starter macrumors regular

    Joined:
    Mar 27, 2007
    #10
    Problem solved! I simply moved my entire iTunes library into my Documents folder, and afterwards I was able to exclude the Movies subfolder from TC backups. Don't ask me why this worked, but I'm happy it did. Thanks for the advice along the way.
     
  11. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #11
    It worked because your permissions for your account are set properly in Documents and not set properly in the Music folder. You still should run through the process I outlined in my post above to get your user permissions set properly. Having user permissions wrong could cause you other problems like this again.
     
  12. dcains thread starter macrumors regular

    Joined:
    Mar 27, 2007
    #12
    I don't know why moving the iTunes stuff worked, but I did reset the permissions as you described first, and still could not exclude the Movies folder from backups. I only tried moving around the iTunes library out of desperation, and I'm happy that did the trick, regardless of why.
     

Share This Page