Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

Ritmo

macrumors member
Original poster
Mar 27, 2009
49
16
Finland
Finally figured out what was taking all the space in my backups.
I thought that the “Apps using iCloud” setting would be controlling whether the messages are backed up, but it seems they’re regardless going to be backed up.
Is there any way to keep them only locally on device?
 

digitalexplr

macrumors 65816
Dec 13, 2016
1,322
870
Central Missouri
Finally figured out what was taking all the space in my backups.
I thought that the “Apps using iCloud” setting would be controlling whether the messages are backed up, but it seems they’re regardless going to be backed up.
Is there any way to keep them only locally on device?
Settings/Apple ID/iCloud under Apps Using iCloud turn off messages from the iCloud backup.
 
Comment

Ritmo

macrumors member
Original poster
Mar 27, 2009
49
16
Finland
Settings/Apple ID/iCloud under Apps Using iCloud turn off messages from the iCloud backup.

Yeah that’s the setting that doesn’t work. Or there’s some duplication happening. You can try it yourself by deleting some large images or conversations from messages “Settings/General/Storage/Messages”. You’ll see your backup size will decrease
 
Comment

PBG4 Dude

macrumors 68040
Jul 6, 2007
3,319
2,826
Yeah that’s the setting that doesn’t work. Or there’s some duplication happening. You can try it yourself by deleting some large images or conversations from messages “Settings/General/Storage/Messages”. You’ll see your backup size will decrease
Do you have any other Apple devices? They may still be set to use iCloud for Messages.
 
Comment

Shirasaki

macrumors G4
May 16, 2015
10,513
4,266
There seems to be no way to disable just message from iCloud backup. The “messages” toggle only enables iCloud messages or not. The stored message still counts as iCloud storage quota. This kinda sucks, I’d argue.
 
Comment

Ritmo

macrumors member
Original poster
Mar 27, 2009
49
16
Finland
Do you have any other Apple devices? They may still be set to use iCloud for Messages.
I have used it but turned it off.
So, I used to have multiple devices under same iCloud account backup. Couple years ago I started using the messages and turned on the iCloud feature. As the messages iCloud size is visible in the iCloud usage bar, I turned it off after a while. Over the last few months however the backup sizes just kept increasing until not even one device could backup. I figured if I turn everything related to iCloud off surely the backup size would go to near 0. But no, it was only when I tried deleting the message history, mainly the images, gifs and stickers(each one you send is saved as separate file btw) the backup started decreasing.

There seems to be no way to disable just message from iCloud backup. The “messages” toggle only enables iCloud messages or not. The stored message still counts as iCloud storage quota. This kinda sucks, I’d argue.
That’s what I feared. Feels a bit strange they would force upload everyone’s messages to the servers without even an option to turn it off. I guess I’ll put my tinfoil hat on and use something else.
 
Comment

PBG4 Dude

macrumors 68040
Jul 6, 2007
3,319
2,826
That’s weird, because messages are definitely not backing up to the cloud on my setup. If they did I’d probably be out of my free space by now.
 
Comment

chrfr

macrumors G4
Jul 11, 2009
11,027
4,588
If you use "Messages in iCloud", then your messages are not included in the iPhone's iCloud backup. If you're seeing iCloud storage used by Messages, that's the Messages in iCloud feature. Apple isn't clear whether having it enabled on any one device in your iCloud account precludes including messages included in the backup on any other device.

 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.