Experiencing huge problems browsing the internet on my MacBookPro

Discussion in 'Mac Basics and Help' started by Giovannino, Sep 17, 2008.

  1. Giovannino macrumors member

    Joined:
    Feb 21, 2008
    #1
    Hi

    I'm experiencing huge problems browsing the internet on my MacBookPro

    About 50% of the sites don't load

    Safari could not open the page “http://URL of the page” because the server is not responding.

    the other 50% are very slow. The same happens with Firefox too. (Safari and Firefox are latest version, Leopard 10.5.5 also experienced the problem before the last update)

    And this is where the (to me) strange part comes:

    - I have no problems viewing those sites on my iPhone using the same WiFI network as my MacBookPro does

    - I only experience problems on my MacBookPro using my home network (where the iPhone works great), at my parents home I have no problems viewing those sites on my MacBookPro

    So to me the problem has to be between my MacBookPro and my Network (Cable modem and Siemens Gigaset SE 551 WLAN) but as previously told the same Network works great together with the iPhone (hence it's not an ISP problem) further I didn't experience any problem until a few months ago and the MacBookPro is working great together with my parents Network.

    - Do I have to change the Siemens WLAN even if it works without any problem with my iPhone?

    - Do I need to reinstall OS X even if it works great at my parents home (and I'm not experiencing any other problem)?

    - Does anyone have any suggestion?
     
  2. fwhh macrumors regular

    Joined:
    Aug 11, 2004
    Location:
    Berlin, Germany
    #2
    Try to use a static DNS server (Network Preferences). (Some Siemens Routers have a problem with that.)
    You should also try to "ping" servers you can not reach in safari, using terminal oder the network utility.
    If that doesn't help, try to change the wlan transmission channel.
     
  3. Giovannino thread starter macrumors member

    Joined:
    Feb 21, 2008
    #3
    I'm not sure how to achieve that. In TCP/IP instead of DHCP I selected Manually and put in the same informations I get when selecting DHCP.

    In DNS where I get the Router address 192.168.2.1 greyed out when selecting DHCP. I entered
    208.67.222.222
    208.67.220.220
    which I found to be open servers by googling.

    Did I do it right? Still no improvements...

    Ping with terminal works for sites I can't reach with Safari and Firefox. It pings data without any problem.

    I didn't find this setting in the router... Do you know where I could find it?

    Vielen Dank, dass du versuchst mir zu helfen
    Giovannino
     
  4. fwhh macrumors regular

    Joined:
    Aug 11, 2004
    Location:
    Berlin, Germany
    #4
    You can use DHCP, but in DNS you should enter the correct address of your ISP's DNS server.
    Be sure you changed it for the correct network device (Airport).
    On your router select "advanced setup" ("Erweitertes Setup"), "WLAN", "basic setup", there should be an option for the transmission channel ("Funkkanal"). (This applies to the Siemens SE505 and SE515 and some others. Should be about the same in your case..)
     
  5. Giovannino thread starter macrumors member

    Joined:
    Feb 21, 2008
    #5
    I tried to change the channel and entering my ISP DNS but it didn't help.

    I then tried resetting the router and tried it out without setting any secutrity encryption. As long as I don't set any security encryption it works well with my MacBookPro. As soon as I set up a password WPA2-PSK and WEP it doesn't work with my MacBookPro anymore but it still does with my iPhone.

    At my parents home where the MacBookPro has no problems there is no WPA2-PSK or WEP encryption on the router, thus it's open.

    I really think my MBP has a problem with network encryption as it works well with open networks.

    Should I try to restore and reinstall Leopard and hope it gets fixed or is there anything else I can try?
     

Share This Page