Export from H.264 results in choppy output

Discussion in 'Digital Video' started by blufire, Feb 26, 2008.

  1. blufire macrumors regular

    Joined:
    Jul 20, 2002
    #1
    Hello, I've been experiencing an issue (I don't remember it happening before the 7.4.1 update) with exporting from an H.264/AAC QuickTime movie. I used to be able to export from H.264 videos (encoded with QuickTime) with no problem. Today, I discovered that exporting any H.264 video (to DV or AIC, for instance) results in choppy output video. It happens when adding an H.264 video to an iDVD project, exporting video with QuickTime Pro, and exporting the same video from Toast Titanium 8.0.3.

    Has anyone else experienced this? I've tried it on both my own H.264 QT movies as well as some of Apple's HD movie trailers. The output is always choppy (maybe ~15 fps, rough eyeballed estimate).
     
  2. huntercr macrumors 65816

    Joined:
    Jun 6, 2006
    #2

    Is the choppyness "in" the video, or in the playback. I mean is it being rendered incorrectly or is it playback?

    I doubt this has anything to do with it, but I noticed with the latest quicktime that HD trailers from the Apple ( M. Night Shyamalan's latest for instance ) were really struggling on my old G5, where as prior to this update I never had any problems.

    I wonder if there has been a code change that caused this. What kind of system are you running on? You say it happened with iDVD too. Does it happen on the burned disc in a DVD player?
     
  3. blufire thread starter macrumors regular

    Joined:
    Jul 20, 2002
    #3
    The choppiness is in the video, despite full frame rate (29.97 fps playback). I'm on an 8-core Mac Pro so I don't think system speed is the problem. ;) And yes, you can see the choppiness on the burned DVD as well. The original H.264 videos play back perfectly smoothly, while any codec export is consistently choppy.
     
  4. blufire thread starter macrumors regular

    Joined:
    Jul 20, 2002
    #4
    Problem solved

    I've found the problem, and it's the Perian 1.1 QuickTime plugin. I removed the plugin temporarily and H.264 export now works perfectly as before. I'm going to notify the Perian developers of this problem.

    [UPDATE] I've reported the problem to Perian's Trac and it's been confirmed and accepted for address. Perian Trac Ticket #320
     

Share This Page