Exporting an anamorphic project for iDVD comes out distorted!

Discussion in 'Digital Video' started by Josephkyles, Apr 22, 2007.

  1. Josephkyles macrumors regular

    Joined:
    Sep 7, 2006
    #1
    I've just finished a huge project in FCE, and I was trying to export the project for iDVD using File>Export>Quicktime Movie. and when it encodes the video it comes out full screen and NOT widescreen! Whats the deal?
     
  2. ppc_michael Guest

    ppc_michael

    Joined:
    Apr 26, 2005
    Location:
    Los Angeles, CA
    #2
    That's a nuisance in iDVD. You can fix this with bitsetting, which is pretty complicated, or you can use iMovie.

    Use iMovie to create a new anamorphic widescreen project and import the video, then use iMovie to send to iDVD.
     
  3. Josephkyles thread starter macrumors regular

    Joined:
    Sep 7, 2006
    #3
    Wow! It says its going to take an hour to import to iMovie!
     
  4. ppc_michael Guest

    ppc_michael

    Joined:
    Apr 26, 2005
    Location:
    Los Angeles, CA
    #4
    If you right-click on your iMovie project file and choose "Show Package Contents," then go into the Media folder and copy your video into there, you shouldn't have to wait for iMovie to do any processing.
     
  5. klaymac macrumors newbie

    Joined:
    Apr 24, 2007
    #5
    The problem lies with iDVD, which doesn't recognize anamorphic movies. There's a quick and easy solution, however, a neat little tool that sets a flag in the exported movie that is recognized by iDVD. It's called Anamorphicizer, downloadable here:

    http://homepage.mac.com/sith33/FileSharing34.html
     
  6. Josephkyles thread starter macrumors regular

    Joined:
    Sep 7, 2006
    #6
    Are you sure that its iDvd? because when I export the project as a quicktime movie, it doesn't show up as anamorphic in quicktime either.

    And when I try to use the anamorphatizer thing I keep getting this error...
     

    Attached Files:

  7. zioxide macrumors 603

    zioxide

    Joined:
    Dec 11, 2006
    #7
    Had this same exact problem last weekend. The solution is easy. Create your DVD image in iDVD and then save it to your hard drive. If you play it back in DVD player, it will still be stretched out. Go and download MyDVDedit and open the DVD image in this program. It will allow you to change the aspect ratio for the VTS tracks. Once you change the ratios to 16:9, you can save the dvd image and then burn it in a program like toast, and you should be all set. :)
     
  8. Josephkyles thread starter macrumors regular

    Joined:
    Sep 7, 2006
    #8
    WOW! Thats this is really complicated, and it really shouldn't be! I'm exporting as a dv stream now, then I'm going to open in iMovie, I hope this turns out ok.
     
  9. Artofilm macrumors 6502a

    Artofilm

    Joined:
    Oct 12, 2005
    #9
    Okay, here's what to do.

    Forget all the exporting as dv or quicktime and import to iMovie, yada, yada, yada.

    Go into your project in FCE and right click in the Bin and create a new sequence. Right click on the new sequence icon and go to sequence preferences. In the preferences, you will see a list of settings, look for one that says the ratio of video. It will most likely be set to Anamorphic 16:9 (because of your anamorphic video). I believe the setting are changed by going thru a drop-down list, use the list to find the ratio of 4:3.

    Once you have found this, accept it, and accept the sequence preferences.

    Make sure your new 4:3 ratio sequence is open, and click and drag your Anamorphic sequence (the one you were trying to export) into the timeline of your 4:3 sequence.

    When you have done this correctly, you will notice that FCE will automatically set the old anamorphic widescreen sequence to fit the new 4:3 full screen sequence. Render if needed.

    Export to Quicktime with desired quality.

    Send to iDVD make sure iDVD is set to Fullscreen (4:3) not Widescreen (16:9)

    To summarize what you did here, since iDVD cannot read Anamorphic widescreen correctly, you have mimmicked the look of widescreen my "letterboxing" the anamorphic into the new sequence. iDVD now does not have to think of trying to set it to widescreen or not, but just knows it's regular 4:3 footage.

    I hope this helps!:D
     
  10. Josephkyles thread starter macrumors regular

    Joined:
    Sep 7, 2006
    #10
    When I do this it just squeezes the 16X9 video to fit 4X3, so its still not 16X9.
     
  11. Josephkyles thread starter macrumors regular

    Joined:
    Sep 7, 2006
    #11
    OK, heres is what I had to do!!........I exported as a DV Stream, when I did this is kept the 16:9 aspect ratio, I'm not sure why the DV stream Export worked but it did, however when I imported into iDvd it went back to 4:3. I then used the Anamorphicizer and now it plays fine!

    This really needs to be fixed!
     

Share This Page