Express card won't stay in slot

mrlunch

macrumors newbie
Original poster
Dec 30, 2006
28
0
San Diego, CA
Purchased the 15 inch MacBook pro about 9 months back and recently got the high speed wireless card (Sprint ExpressCard EVDO - EX720). It was working the first few times I used it. I had remove the card this morning from the slot…and now it won’t stay in.

Card still works as long as I hold it in with one hand. But one hand computing is not very fun or comfortable.

Went to the Apple store and tried to see if it was the card or the MacBook. Inserted the card and it locked in like it should on the MacBook Pro at the store.

I was told I would need to leave my computer with them for 5 days so they could check it out. Told them I need to come back later to drop it off.

Did anyone else have this problem?
 

mrlunch

macrumors newbie
Original poster
Dec 30, 2006
28
0
San Diego, CA
It's an issue with the Apple ExpressCard slot design. Get it replaced under warranty
Ok, should I call tech support or go to a apple store.

I went back tot he apple store and waited for about an hour at the Genius Bar and couldn't wait any longer and had to go.
 
Comment

Chundles

macrumors G4
Jul 4, 2005
11,972
385
Yep, definitely an issue - seen two of the same problem here at the store. Get thee to an Apple service centre.
 
Comment

CanadaRAM

macrumors G5
If you have an independent Apple Authorized service dealer locally, I would try there first. I trust our local authorized technicians more than some repair centre in a far off city.

(Hi Chundles! haven't seen you around for a while.. )
 
Comment

Cattywampus_

macrumors 6502a
Apr 19, 2006
511
21
Hi guys,

I have a MBP 1.1. I use a Firewire 800 card from Siig. The card stays in, but you only have to slightly pull it and it comes out - does stay in though and that. Should it be in securely though? I.e. once its clicked in I should have to push it in and click it again for it to come loose? Or shoudl I just be able to gently pull it and it comes out?
 
Comment

wow

macrumors newbie
Jun 9, 2004
2
0
Add two more problems MBPro's here. One 17" and one 15" . Both worked for a short time with the very same high speed wireless card (Sprint ExpressCard EVDO - EX720), then both failed. The MBPro's are out of warranty. We didn't get the cards until after the warranty period was over, but both slots failed within weeks. This sure seems like an expresscard cage issue?
 
Comment

mrlunch

macrumors newbie
Original poster
Dec 30, 2006
28
0
San Diego, CA
Add two more problems MBPro's here. One 17" and one 15" . Both worked for a short time with the very same high speed wireless card (Sprint ExpressCard EVDO - EX720), then both failed. The MBPro's are out of warranty. We didn't get the cards until after the warranty period was over, but both slots failed within weeks. This sure seems like an expresscard cage issue?
I talked with a third-party apple specialist and he said that apple obviously knows the ExpressCard is faulty because the replacement apple sends out is constructed differently. basically they know it's a problem but aren't admitting to it. fortunately my MBP is still under the warranty but it will take a few weeks for them to get the part and get this they wont order the part until I leave the computer with them. So I'll be without my laptop for a few weeks. Kind of lame.
 
Comment

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.