ext hdd mounting issue

Discussion in 'Mac Basics and Help' started by acupofkopi, Nov 7, 2013.

  1. acupofkopi macrumors newbie

    Joined:
    Nov 7, 2013
    #1
    Hi guys,
    really don't know what else can or where else to ask about this,

    I'm using the macbook pro retina with mavericks.
    bought a seagate 4tb desktop hdd with vantec usb 3.0 enclosure
    these two combination will not mount on my mbp
    it would not mount and is the hdd does not appear in my disk utility as well.
    tried going to terminal with the command diskutil list and the hdd is no where to be found as well.

    however, the same combination when plugged to windows is mounted.

    so far, i've tried :
    - mount the disc to windows, format it to gpt nfts = can't mount
    - mount the disc to windows, format it to gpt exfat = can't mount
    - mount the disc to windows, format it to gpt hfs using paragon hard disk manager = can't mount too.

    i took apart and plug the hdd to my old western digital enclosure which is connected with usb 2.0, the disc is mounted, saw it in disc utility but only 1.8TB.

    i'm quite sure when i bought the hdd and enclosure, both said it is compatible with the mac.
    i'm not sure what is wrong....is it the cable...or...?
    because i also tried using a usb 2.0 cable to connect them and still it won't work.
     
  2. macs4nw macrumors 601

    macs4nw

    #2
    I'm assuming you have formatted the hdd for Mac? There are currently some well-documented compatibility issues between Mavericks and certain brands of HDDs.
    http://macdailynews.com/2013/11/01/...essibility-after-os-x-mavericks-installation/
    http://www.pcpro.co.uk/news/385171/os-x-mavericks-wipes-data-on-western-digital-drives

    I've seen WD, Seagate and LaCie all mentioned in various blogs. I would say don't panic, and hang tight. Solutions are coming.
     
  3. acupofkopi thread starter macrumors newbie

    Joined:
    Nov 7, 2013
    #3
    hi,
    yeah..i've tried formatting them to apple hfs and still unmountable.
    but with the same said formatting, when enclosed with a wd case, it's mountable and read-writable.

    also, i tried the same thing with my friend's imac that's still running mountain lion. also can't be mounted and doesn't appear on disk utility.

    if the box of the enclosure doesn't say that it's compatible with mac, then i'm pretty sure it's the enclosure problem but here, the box clearly writes that it's mac compatible : /

    the whole hdd works fine with windows though.
     
  4. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #4
    Hmmm... the enclosure you bought should come with an external power supply block.

    Are you using it?
     
  5. macs4nw macrumors 601

    macs4nw

    #5
    In light of the above, I would contact Seagate (and Vantec, as well as WD) customer service, and let them give you suggestions on your next steps. They may be aware of compatibility issues with you particular drive/enclosure set-up combination. Good Luck!
     

Share This Page