Extenal drives suddenly are not read/writable

Discussion in 'Mac Basics and Help' started by bulbasaur, Sep 7, 2009.

  1. bulbasaur macrumors newbie

    Joined:
    Sep 7, 2009
    #1
    I have three external drives, two it seems are no longer writable for some reason. All three drives were read/writable on my IMAC running leopard 10.5.8 I can't figure out how the drives would have changed format from Mac Os Extended (journaled) to Windows NT (I've cleaned out some programs I hadn't used in a while and we had a power failure once).

    What would cause the format to change suddenly and how do I fix the problem without dumping everything on the drives?? HELP!
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    They wouldn't have. If they're NTFS, they must have been formatted that way. Doing so requires that the drive be erased. My guess would be that the drives were always formatted as NTFS, but you just didn't notice because they worked fine.

    I'm assuming you have NTFS-3G installed, yes? If so, you can restore read/write capability by connecting the drives to a Windows computer (or your Boot Camp install if you have one) and ejecting them properly.
     
  3. bulbasaur thread starter macrumors newbie

    Joined:
    Sep 7, 2009
    #3
    The two drives were previously used on a windows cpu, when I bought my IMAC I realized they were unwritable. I then bought a new 1TB drive just to transfer all my data too in order to reformat the drives to make them OS X compatible. I reformatted them to MAC OS extended Journaled, I was then able to use them for the last 6-9 months or so, read/writing business as usual.

    I wake up one day and no longer can and the old format is back????!! I don't know if there was a program I got rid of that formated them or made them useable but I can't figure out how they were useable but all of a sudden "change". Weird.

    How can this happen??
     
  4. bulbasaur thread starter macrumors newbie

    Joined:
    Sep 7, 2009
    #4
    I don't think they could have been NTFS and still have worked for months could they??

    I don't know what NTFS-3G is.

    I can eject them on the IMAC now.
     

Share This Page