Extended Keyboard Problem

Discussion in 'Mac OS X Lion (10.7)' started by sidewinder, Aug 17, 2011.

  1. sidewinder macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #1
    Okay, I think I have my first 10.7.x problem. The number keys on the keypad on my aluminum extended keyboard do not work. All the keys around the numbers seem to work fine. The keys work fine on 10.6.x.

    I have hit the "clear" key and it has no effect. I have made sure that the "U.S. Extended" keyboard is selected in Keyboard Preferences. I even selected the plain old "U.S." keyboard and had the same results.

    I have logged in and out of my account and even rebooted. I have even reset PRAM.

    Suggestions?

    Scott
     
  2. Nuckinfuts macrumors 6502

    Joined:
    Jun 15, 2011
    Location:
    Syracuse, NY
    #2
    I'm assuming it's the same keyboard I'm using ($50 aluminum apple wired keyboard) and my numpad works fine, have you tried re-running the keyboard detection?
     
  3. sidewinder thread starter macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #3
    Same keyboard....okay, I have never had to do this before...how do I re-run keyboard detection?

    S-
     
  4. Nuckinfuts macrumors 6502

    Joined:
    Jun 15, 2011
    Location:
    Syracuse, NY
    #4
    System Preferences -> Keyboard
    button in the lower left "Change Keyboard Type" brings up the detection wizard for me
     
  5. sidewinder thread starter macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #5
    Don't have that option in:

    System Preferences -> Keyboard

    Any other ideas?

    S-
     
  6. sidewinder thread starter macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #6
    I logged into my wife's account on the system and the keyboard works fine there......

    S-
     
  7. sidewinder thread starter macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #7
    It ended up being one of these plist files:

    ~/Library/Preferences/com.apple.KeyboardViewer.plist

    or

    ~/Library/Preferences/com.apple.universalaccess.plist

    I deleted both, logged out and back in and the problem was gone. I suspect the first plist file was the culprit. It is interesting to note that the first plist file has yet to be recreated.

    S-
     
  8. HermosaJulieJo macrumors newbie

    HermosaJulieJo

    Joined:
    Jan 6, 2013
    #8
    Worked for me

    Only had the UniversalAccess plist file to delete, logged out and back in and "voila" - Thanks!!

    :D
     

Share This Page