External display issue

Discussion in 'MacBook' started by Frizers, Aug 17, 2016.

  1. Frizers macrumors regular

    Joined:
    Jul 18, 2013
    #1
    So I've got an external Acer 27" USB-C display (http://www.acer.com/ac/en/US/content/series/h7) connected to my Macbook 12" (2016) which I've been using for a month or so and I've got some pretty serious issues with it, which may be down to the macbook but I am unsure. After an initial problem getting the display to cover the whole screen instead of letter boxing (requiring restarting in Safe Mode to fix), I still have persistent problems:

    1. The main issue: when plugging the display in (AFTER having used the laptop for a bit), the display will go blank for a second (and lose audio output) intermittently, and without any consistency, either every 2 minutes, or it might last 20 minutes before doing this. The only way to avoid this problem I have found is to restart my laptop and then plug it into the display each and overtime.
    2. IF the computer goes to sleep whilst connected and is woken up still connected, IF it will wake up, the audio defaults to the macbook (with no output from the screen being listed) requiring being unplugged and plugged in again; and the problem above (1) returns
    3. I CANNOT start-up the laptop after a shutdown whilst plugged into the display. If I do this, both screens remain blank after the start up chime, and I have to reset the NVRAM (and obviously disconnect the display) to do anything. (I can live with this problem but its annoying)

    If it makes any difference, these problems persist in Bootcamp BUT a day ago when I restarted from Windows into Mac, I was able to do this without removing the cable - so apparently it can be done. I have ordered another usb-c cable which I will try tomorrow (the only one I've used is the one that came with the display as the one with the laptop does not do more than usb 2.0 speeds).

    If anyone has any ideas they would be greatly appreciated.

    Cheers
     
  2. Salty Pirate macrumors 6502

    Salty Pirate

    Joined:
    Oct 5, 2005
    Location:
    kansas city
    #2
    i bought that display, used it for an hour and promptly returned it. It sucks. Flickered on and off. Screen quality was terrible.
     
  3. grinny11 macrumors regular

    Joined:
    Aug 12, 2008
    #3
    I have the same first problem you have with a Cinema Display and the USB-C to display port adaptor. I think its a rMB problem. I Have a 2016 m3.
     
  4. Frizers thread starter macrumors regular

    Joined:
    Jul 18, 2013
    #4
    The thing is when plugged into an Anker to HDMI/ 2 x USB 3.0 adapter, it outputs via hdmi without an issue
     
  5. bcaslis macrumors 68020

    Joined:
    Mar 11, 2008
    #5
    I've been using that display for a couple of days and the display has been great. No flickering, no audio problems. However yesterday it seemed like the USB 3.0 ports had died nothing was working. Today everything seemed to work fine. I'm going to wait and see if the problem comes back. I think the display is fine but there may be some duds out there.
     
  6. pshifrin macrumors 6502

    pshifrin

    Joined:
    Mar 14, 2010
    #6
    I have the same problem with a 2016 m7, OWC dock and Dell 1440p display. Sometimes I plug in and it works perfectly and sometimes the screen keeps going black and have to reboot.
     
  7. Frizers thread starter macrumors regular

    Joined:
    Jul 18, 2013
    #7
    That's interesting. I've phoned acer and sent it back for a repair. Whatever luck I'll have with that I don't know. I had to say I'd tried it with multiple computers despite having not, seeing as no one I know has a usbc computer. Will report back whether I have any luck. If problem persists I'll go to apple and try that route but what bcaslis says gives me hope I should get it working eventually!
     
  8. barryblack macrumors newbie

    Joined:
    Aug 26, 2009
    #8
    I'm using a dell U2715H with a 2016 MB and this sounds like the problem I'm having. Randomly, the screen goes black for like 5 seconds and then turns back on. I've reset my pram and pmu. I'm using the apple hdmi adapter and I've tried it with different hdmi cables. Not sure what to do but it's driving me nuts.
     
  9. JTToft macrumors 68040

    Joined:
    Apr 27, 2010
    Location:
    Aarhus, Denmark
    #9
    With this many different monitors and adaptors involved, it has to be an issue on the rMB's part.
     
  10. doboy macrumors 68000

    Joined:
    Jul 6, 2007
    #10
    I too see some issues with my m7 rMB. I really think it's the issue with the computer.
     
  11. barryblack macrumors newbie

    Joined:
    Aug 26, 2009
    #11
    Still happening with os x sierra. Also happening after replacing my dell U2715H with a new dell U2717D that I got from work.
     
  12. iDemiurge macrumors 6502

    iDemiurge

    Joined:
    Feb 7, 2011
    Location:
    Portugal
    #12
    I don't get the random blackouts, but I do have an issue with the external display not being recognised after a reboot when in clamshell mode. Dell U2515H and 2015 rMB here.
     
  13. barryblack macrumors newbie

    Joined:
    Aug 26, 2009
    #13
    I'm going to buy a CalDigit USB-C Docking Station and see if that fixes things.
     
  14. PDE macrumors 68020

    Joined:
    Nov 16, 2005
    #14
    I'm using a macbook retina 2016 with an apple multimedia dongle and a Dell U2515H. I had zero problems with it when running el Capitan, but with Sierra have random blackouts that last for a second or two. They seem to happen in the first hour after waking from sleep and not so much later, but that could just be coincidence.

    Since I started using a powerbook 540c in the mid-90s I've never had an external display issue, and don'[t think anyone should have these kinds of issues in 2016. Not sure what the solution is, but hopefully Apple will come up with a fix for this eventually.
     
  15. barryblack macrumors newbie

    Joined:
    Aug 26, 2009
    #15
    I bought a CalDigit USB-C Docking Station and the problem is still there. They told me to reset my PR ram. That worked for a day but now the blackouts are back. I really don't want to have to restart my computer ever morning but the blackouts are driving me nuts.
     
  16. gthompson20 macrumors member

    gthompson20

    Joined:
    Jun 22, 2010
    Location:
    Indiana, USA
    #16
    This is an issue that A LOT of 2016 owners are facing.. best advice is to open a ticket with Apple Support.. they need to hear from a lot of us to know this is a real issue that needs to be fixed. Here is the apple thread:
    https://discussions.apple.com/thread/7615336

    Please open a ticket with Apple Support!
    --- Post Merged, Oct 28, 2016 ---
    Here is a short video showing the issue.. This is a 2016 MacBook with the official apple HDMI adapter:
     
  17. Frizers thread starter macrumors regular

    Joined:
    Jul 18, 2013
    #17
    So after sending the display to acer, they replaced the panel and returned it. Same problem existed but with a new bonus- the sound was not working either. I returned the display with great difficulty and bought a 25inch dell with a similar screen, plugged in via an anker hdmi USB adapter. I can now switch the laptop on whilst plugged into the display but if I plug it in after some time I still have the issue of the screen flickering and other issues. Going to see if I can swap the MacBook as this is really getting annoying.
     

Share This Page