External Display, No Cursor Shadow

Discussion in 'macOS' started by MarcBook, Oct 2, 2009.

  1. MarcBook macrumors 6502a

    MarcBook

    Joined:
    Jul 13, 2008
    Location:
    Jersey, Channel Islands
    #1
    I tried searching MRs for this topic, even used MRoogle and didn't find anything, so forgive me if it's already been covered.

    I use my MacBook Pro (details in my signature) with my 20" Apple Cinema Display in lid-closed/clamshell mode. I regularly put it to sleep and I've noticed that upon waking the machine the shadow under my cursor is gone.

    The cursor shadow won't come back until the computer is rebooted, so it's definitely a bug with it waking up from sleep. This only happens on the external display. It does not happen when it's being used normally with the built-in display.

    I know it's not exactly a big issue, but the cursor looks surprisingly yucky without the shadow, like I trip back in time to OS 10.0... :( Or as if my Mac can't handle Quartz Extreme. :p

    Has anybody else noticed this? I think it's only popped up (or disappeared, rather) since Snow Leopard, although I may be wrong. Any solutions, such as a way to restart the cursor-rendering process, would be great.

    Thanks in advance.
     
  2. RikT macrumors newbie

    Joined:
    May 17, 2008
    #2
    I'm having exactly the same problem, does anybody know a solution?
     
  3. PurrBall macrumors 6502a

    PurrBall

    Joined:
    Oct 25, 2007
    Location:
    Indianapolis
    #3
    This has always been a bug since the new cursor was introduced in 10.2. The only fix I've found is a reboot.
     
  4. RikT macrumors newbie

    Joined:
    May 17, 2008
    #4
    Wow, that sucks. Anyway, I noticed just logging out is enough to get the shadow back.
     

Share This Page