External Drive Dilemma

Discussion in 'macOS' started by Jimillenium, Aug 29, 2010.

  1. Jimillenium macrumors newbie

    Joined:
    Jun 18, 2010
    #1
    Hi,

    This is a bit of a strange one.

    I am using an external USB hard drive with three partitions, 1 for Mac files, one for Windows files and one for media. I can access all of the files on the Mac and Windows partitions (both set up as journaled), but only half of the .avi files on the Media partition (setup as NTFS).

    This only happened recently. I was able to view all of the films up to about a month ago, and now when I try and play some of them I get:

    Item '<filename>.avi' is used by Mac OS X and can't be opened.

    This has affected some files that have been on there for over a year, and some that are very new. I can't delete the file, move, or copy it to my laptop hard drive. This partition is NTFS, and can be accessed perfectly well on a Windows machine.

    I have installed and tried SL NTFS but it cannot make the drive writeable. Within a Windows environment I have searched for,and fixed, any drive errors found and then safe ejected the drive to ensure that the NTFS permissions are not corrupted. The drive has Full Control to everyone aswell, to make sure there are no permission issues there.

    As it's NTFS I can't repair permissions on the Mac as it won't acknowledge it through DIsk Utility.

    Any suggestions are most welcome. TIA.

    Jim
     
  2. olidpass8 macrumors newbie

    Joined:
    Apr 14, 2010
    #2
    Same problem

    I have a small but annoying problem.

    Set up:
    MacBook Intel Core 2 Duo with an external hard drive (WD Passport) in NTSF format.
    I've used a third-party software and CAN READ AND WRITE to the external hard drive.
    There are two movie files in .mkv that are grayed out.
    Every time I tried to use VLC to play these files, I get "item whatever.mkv is used by Mac OS X and can't be opened"
    There are many other movie files in .mkv on the same external hard drive that I can play with VLC on my MacBook.
    I plug the same external hard drive to my Windows notebook and use VLC to play these grayed-out .mkv files WITHOUT ANY PROBLEMS!

    I need to help to release Mac OS X from using these files.

    I've tried everything that I can think of:

    1. I've copied the files in Windows to another location, but when I put the drive back in Mac, the copied files are grayed out too.

    2. I've copied the files in Mac to another location but the files would DISAPPEAR after copying.

    3. I've used OnyX and unhide all files on my external hard drive and MacBook internal hard drive and I don't see any copies of these 2 grayed out files I made. I still see the same 2 grayed-out files like before.

    So any ideas or tips are appreciated!
     

    Attached Files:

Share This Page