External drive dosn't work anymore.

Discussion in 'MacBook' started by Wraz, Sep 23, 2009.

  1. Wraz macrumors regular

    Joined:
    Jun 1, 2009
    #1
    Im not sure where to post this but.
    I dont know what happen, but my Digital western external harddrive dosn't work anymore?
    I can see the files but i can only copy the files from it and transfer to my mac.
    I cant read or write? what do i do?
     
  2. patrickdunn macrumors 6502a

    patrickdunn

    Joined:
    Apr 16, 2009
    Location:
    St. Louis, MO
    #2
    Right click on the drive>Get Info>Permissions

    Un-check Read-Only.

    Did that help?
     
  3. Wraz thread starter macrumors regular

    Joined:
    Jun 1, 2009
    #3
    Already tryed that. but i can't seem to change it.


    But as you can see on the screenshot. its on danish, but basicly wat is say is that i can only read.
     

    Attached Files:

  4. Cave Man macrumors 604

    Cave Man

    #4
    The drive was initialized as NTFS out of the box. You need two apps to read it: NTFS-3G and MacFUSE (both freeware). Install them then you can read/write to the external. Unless you have a compelling reason to keep it as NTFS, then you should consider reinitialize the drive as HFS+ with journaling (after retrieving any critical files from it).
     
  5. OriginalFormula macrumors regular

    Joined:
    Apr 14, 2009
    #5
    Use Disk Utility to reformat into either HFS+ or FAT32.
     
  6. Wraz thread starter macrumors regular

    Joined:
    Jun 1, 2009
    #6
    That would delete all my files right?
     
  7. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #7
    Yes, it would.

    But before you bother installing 3rd party drivers to read the NTFS, Snow Leopard has this function built-in, but you have to enable it. Here's a thread that details that process:

    http://forums.macrumors.com/showthread.php?p=8477762&posted=1#post8477762

    This ONLY works on Mac OS X 10.6 Snow Leopard.
     

Share This Page