External Drive - filename -> file mix up!

Discussion in 'Mac Basics and Help' started by Mikrogen, Feb 2, 2010.

  1. Mikrogen macrumors newbie

    Joined:
    Jan 17, 2009
    #1
    Hi guys,

    I have a 1Tb Iomega Minimax attached to my Mac mini that has started acting strangely.
    It would appear that some of the file names have become linked to other files on the hard drive.
    Example - I can double click on an mp3 file that used to be fine, but now a video file gets played that is stored elsewhere on the Minimax.

    It only appears to be some of my files. I use this drive mainly for mp3 and AVI video storage so the mix ups are typically between these file types.

    I ran disk utility but it says the drive is fine. Is there any other Mac software that can help me figure out what the problem is and maybe fix it?
    I've never seen a hard drive do this before, and my Mac experience is pretty limited!:confused:


    Edit:: I just realized this should probably go in the "Mac accessories" section. Sorry!
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Have you tried repairing the volume with Disk Utility?

    Edit: Sorry, reading comprehension fail.
     
  3. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #3
    If Disk Utility says its ok, that's particularly weird. You can get cross-linked files on a badly corrupt drive, but usually the data in the file is too garbled to play anything at all, rather than opening another specific file.

    Couple of questions that might help troubleshoot:

    Is this drive formatted as FAT or HFS? (If you select the volume in question in Disk Utility, it will show the format in the "Format" item at the bottom.)

    And, if you do a "get info" on the weird files, does the size show a number that looks more like what the file is supposed to be, or what you get when you double-click it? (I'm assuming if they're MP3s and video files there's a big enough size gap it should be obvious.)

    Finally, if you double click something and get the wrong file, what happens if you find that specific wrong file and double click it? Do you get the same thing, or the other file (the one you tried first)?
     
  4. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #4
    When you say "an mp3 file", is it possible you're double-clicking an alias of an mp3 file?

    If it's icon shows a small curved arrow at lower left, it's an alias file.

    If you do Get Info on it, and one of the General info items says "Original", it's an alias.

    If you right-click (or control-click) it and one of the contextual menu items is "Show Original", it's an alias.
     
  5. Mikrogen thread starter macrumors newbie

    Joined:
    Jan 17, 2009
    #5
    Hi, thanks for offering help.
    In answer to your questions:-

    It says it is Mac OS Extended (Journaled).

    One of the files is an MP3 with a file size of 10.7MB, which is probably about correct. If I select the file iTunes tries to open it unsuccessfully, however if I select "Open with VLC" I get about 1 minute of an AVI file that is actually about 1 1/2 hours in size. It is a section in the middle of the film!!

    The AVI file plays in full when opened without any problems!!
     
  6. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #6
    Based on that I correct what I said before; this sounds exactly like the behavior you'd expect with a crosslinked file. That is, the "file" you see in the Finder is pointing to the wrong chunk of data on the disk. Said data, presumably, consists of a random chunk of another file, in this case an AVI. iTunes, obviously, tries to open it as an MP3 and sees a corrupt file. VLC checks the data itself and is apparently able to play some video out of it even without the header.

    I'm failing to see why running Repair Disk isn't detecting this issue (though I'd be skeptical of its ability to fix it). Are you sure you're clicking the right button (as opposed to a permissions repair) with the physical drive selected (the least-indented item in the left pane, not the volume name underneath)?

    If you have another disk utility on hand, like TechToolPro, you could try that, but even if something does claim to "fix" the issue I'd back up anything not already backed up off the drive (already-corrupt files are probably a lost cause, though you could try Data Rescue), completely reformat it, and start over. If it's a hardware problem this may be the first sign of total failure, or it could have just been a fluke, if severe, corruption of the contents when the drive got unmounted improperly or something. Either way you're better off starting clean than trying to fix it "on the fly".
     

Share This Page