External drive has gone invisible

Discussion in 'OS X Yosemite (10.10)' started by iPhil, Sep 4, 2014.

  1. iPhil macrumors 68040

    iPhil

    #1
    Some how my external drive is invisible from finder/ desktop . But shows in Disk Utility with 1 drive icon and won't unmount from disk utility either ..


    I thought it was a bad cable / adapter ( fw800 ) then tried the USB 3.0 adapter via 3.0 to 2.0 cable still no luck ..

    Ideally I wanna just unhide the drive since its my tunes / movies drive ..


    I did verify / repair the drive came out -- Ok on both
     

    Attached Files:

  2. j800r macrumors regular

    Joined:
    Jan 5, 2011
    Location:
    Coventry, West mids, England
    #2
    hmmm...the drive COULD still be dying. I had that with my old backup drive. Otherwise more beta troubles I guess. My current backup external is functioning fine so I wouldn't know what to tell you other than report it as a bug to Apple and test the drive on another device if at all possible.
     
  3. iPhil, Sep 4, 2014
    Last edited: Sep 4, 2014

    iPhil thread starter macrumors 68040

    iPhil

    #3


    The drive is only 18 months old and no clicking sounds either.. My other drive is bare drive that was connected via USB sled had my Movie drive connected via FW sled..

    I'm booting thru FW on SSD..


    Edit: this post is what I was "trying" to fix going thru the steps but turn on invisible switch on for the drive that i'm now trying to "unhide" now ...

    Yes I have the same "bug" showing Huge storage amounts on drives and i thought by "using" the link above might resolve the issue but it created another big issue for me invisibly of said drive ..
     

Share This Page