External drive keeps spinning down

Discussion in 'Mac Accessories' started by maverick808, Jun 22, 2008.

  1. maverick808 macrumors 65816

    maverick808

    Joined:
    Jun 30, 2004
    Location:
    Scotland
    #1
    Even though I've unchecked the option to "Put the hard disk(s) to sleep" in Energy Saver prefs my MyBook external drive connected to my Mac Mini still spins down after about a minute. The reason this is annoying is because I use that machine as a server sharing files so whenever I connect to the network share Finder locks up for a few seconds while waiting for the drive to spin up.

    I've read other posts on other forums which seem to suggest this is now a common problem. That is, OS X seems to frequently (maybe even always) ignore the "put the hard disk to sleep" for all external drives.

    Does anyone have a solution for this? I just want my external drive to always be spinning so as to avoid the annoying Finder lock ups when I connect to it over the network.

    Edit: I've also tried the SpindownHD dev tool to set the drives to never sleep, but it doesn't make a difference either and the external ignores these settings and still spins down.
     
  2. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #2
    Which MyBook edition is it? There were some issues with early MyBook external drives that did exactly this (i.e. spin down of their own accord), but later firmware updates have supposedly resolved the problem
     
  3. maverick808 thread starter macrumors 65816

    maverick808

    Joined:
    Jun 30, 2004
    Location:
    Scotland
    #3
    Thanks for replying. It's a two-month old 1TB Essential. I checked the WD website for firmware updates but there aren't any for my model. I see the home editions have a firmware update for leopard, but I don't think that addresses the issue as it seems to only fix the drive disconnecting, which isn't the problem I'm seeing.
     
  4. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #4
    It's a feature on the drive, so there is really no way to avoid it. The "prevent sleeping" only applies to the internal drive I think...
     
  5. sickmacdoc macrumors 68020

    sickmacdoc

    Joined:
    Jun 14, 2008
    Location:
    New Hampshire
    #5
    Right you are. An article in Western Digital's Knowledgebase points out quite clearly that there is nothing a user can do- it is a permanent "feature" that can not be disabled. They say it happens after 10 minutes of inactivity. See
    http://wdc.custhelp.com/cgi-bin/wdc...2VhcmNoX3RleHQ9c3BpbiBkb3du&p_li=&p_topview=1

    (or http://tinyurl.com/4k6r5e if that whacko long URL does not work!)
     
  6. maverick808 thread starter macrumors 65816

    maverick808

    Joined:
    Jun 30, 2004
    Location:
    Scotland
    #6
    Thanks for the reply and conclusive answer. Ugh though, what a horrible "feature". I wish I'd known this before I bought the drive as I definitely would have avoided it :(
     
  7. sickmacdoc macrumors 68020

    sickmacdoc

    Joined:
    Jun 14, 2008
    Location:
    New Hampshire
    #7
    Yeah, I have to agree with that. Unfortunately for me I did not discover that until I had purchased six 500 Gb units from Costco and used them in my backup drive array. Could have returned them easy enough, but I did not realize this until I already had backed up a bunch of data to them and then got too lazy to undo it! :mad: That was about 18 months ago, so I would have hoped they had changed that in the newer editions, so sorry to see that they have not!
     
  8. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #8
    Interestingly enough, although the MyBook Studio edition is listed as spinning down, my 1TB connected via firewire 800 doesn't appear to spin down.
     

Share This Page