External Drive leaving directories in /Volumes

Discussion in 'macOS' started by focalplane, Mar 4, 2009.

  1. focalplane macrumors member

    Joined:
    Aug 25, 2007
    #1
    I have a strange problem, I have an external FW800 drive labelled "DataTank" with my Parallels VM's on, and recently i noticed on a few occasions that Parallels could not find the VM's on startup and I had to locate them.

    I noticed in a save dialog tonight multiple copies of DataTank, but all except one had a red X on them.

    I unmounted the drive and looked in /Volumes and there are 4 DataTank folders, labelled

    DataTank
    DataTank 1
    DataTank 2
    DataTank 3

    All are owned by root in the admin group and have d--x--x--x permissions.

    So when the drive mounts its now mounting as DataTank 4

    I seem to be unable to remove them. any ideas?

    Thanks
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    I've seen this happen before. These sometimes get left behind when a drive, for whatever reason, is not unmounted properly - for example, when the computer suddenly shuts down due to power failure.

    This is easy to fix, though you need administrative permissions to do it, and a lack of fear of a few Terminal commands. (Make sure you do this while the DataTank drive is NOT mounted!)
    Code:
    cd /Volumes
    sudo rm DataTank\ 3
    sudo rm DataTank\ 2
    sudo rm DataTank\ 1
    sudo rm DataTank
    
    After that's done, restart just to be safe, before mounting the DataTank drive again.
     
  3. LtRammstein macrumors 6502a

    LtRammstein

    Joined:
    Jun 20, 2006
    Location:
    Denver, CO
    #3
    Do those folders contain anything? It might be best to do this:

    Code:
    cd /Volumes
    sudo rm -rf DataTank\ 3
    sudo rm -rf DataTank\ 2
    sudo rm -rf DataTank\ 1
    sudo rm -rf DataTank
    
    The -rf means it will recursively remove things and force the folder to be removed. I find it to be a bit better because sometimes just doing an rm won't remove the folder.
     
  4. focalplane thread starter macrumors member

    Joined:
    Aug 25, 2007
    #4
    Thanks

    Thanks guys.

    Was sure i'd tried this, though must have only tried sudo'ing from my normal account, which isnt in the sudoers list.
     

Share This Page