External drive missing in Finder on Tiger - showing in My Computer

Discussion in 'macOS' started by askywalker, Dec 12, 2007.

  1. askywalker macrumors regular

    Joined:
    Aug 18, 2007
    #1
    My 1 TB External drive has been working perfectly for a few weeks - connected to new 15" MBP via FW400. It has two partitions - HFS and Fat32. Both partitions have shown up in Finder whenever I plug it in.

    A few days ago the FAT32 partition stopped showing up in the Finder mounts. Strange thing is the top left Finder icon is 'Joe's Computer' lists both, so I can still browse to files on it. When I open Disk Utility (I am learning a lot about Mac's!) I see it listed, and can do a Verify Disk that passes. Each time I click Verify Disk I keep thinking it is mounting it - cause it pauses for a second on 'Mounting disk', and then gives me the green 'volume passed verification'. The results of the verify are:
    Verifying volume “MYFAT32”
    ** /dev/disk1s2
    ** Phase 1 - Read FAT
    ** Phase 2 - Check Cluster Chains
    ** Phase 3 - Checking Directories
    ** Phase 4 - Checking for Lost Files
    Next free cluster in FSInfo block (11362182) not free
    fix? no
    91155 files, 2396288 free (3744900 clusters)
    Mounting Disk

    1 non HFS volume checked

    Some apps easily let me browse to this drive (because they let me browse the 'Computer' tree. But some don't - and it is weird. And weird sucks with important data.

    I have tried unplugging many times, tried relaunching Finder, and read tons of posts here. I was just getting comfortable with the way the Mac mounts disks - I really liked it. Can anyone suggest something that might get my drive to appear again?
     
  2. askywalker thread starter macrumors regular

    Joined:
    Aug 18, 2007
    #2
    My bad - I fixed this by checking the settings in the Finder Preferences. For some reason there was a - instead of a 'check' beside hard drives. It was listing some but not all drives - not sure how that could have happened, but checking this made both drives appear. :D
     

Share This Page