External Drive Mounting Problems

Discussion in 'macOS' started by jahlinux, Jun 11, 2010.

  1. jahlinux macrumors member

    jahlinux

    Joined:
    Jul 18, 2008
    #1
    My iMac has been very unstable lately, frequent lockups. I had to turn off the computer by holding in the power button a couple of times. Sometimes it starts up and other times it just sits at a blue screen. My Time Machine external FireWire drive may be failing. Sometimes it does not mount. It shows up in Disk Utility and I have tried the repair function and then finally reformatted it. Thought everything was fix and after Time Machine made a new backup I entered Time Machine and the computer locked up again. Shut off the computer again, and again it started up and stop at a blue screen, restarted it again and it fully started.

    Again the Time Machine drives does not mount. Also a portable USB drive will not mount, I get and error about not being properly unmounted. The USB drive works fine in my MacBook.

    What would cause the iMac to not mount any external drives? Can a failed drive that does not get unmounted correctly corrupt the iMac to the point it can't mount any external drive?
     
  2. Hal Itosis macrumors 6502a

    Hal Itosis

    Joined:
    Feb 20, 2010
    #2
    Have you checked out this iMac with Disk Utility? (verify both disk and perms).

    Let's see this listing:

    ls -Orbitlake /Volumes
     
  3. jahlinux thread starter macrumors member

    jahlinux

    Joined:
    Jul 18, 2008
    #3
    Looks like it was the Time Machine USB Drive. I'm just suprised how it messed up the ability to connect another USB drive. I have verified the iMacs hard drive with disk utility. Also the portable USB Drive works now but I needed to connect it to my MacBook first, then once I was able to properly unmount it, it worked on my iMac.
     

Share This Page