External Drive no longer detected

Discussion in 'macOS' started by RandmTask, May 1, 2015.

  1. RandmTask macrumors newbie

    Joined:
    Aug 26, 2009
    #1
    Hi,

    My 2011 Mac Mini wouldnt boot because the disk was full (128gb SSD). It would get half way through the progress bar and then shut down. Running fsck was giving Disk Full and Keys Out of Order messages in Single User mode.

    I managed to resolve the problem (After many hours) by booting into Single User mode, delete a whole heap of files (my iPhones *.ipa Application files which freed up 35gb of space - nothing else deleted) then used a bootable version of DiskWarrior 5 and now my computer boots fine again.

    However, I also have two external HDD attached. A 1TB portable Seagate GoFlex and a desktop 2TB Seagate Backup+

    Now, my 2TB drive works fine but my 1TB drive can no longer be found in Finder, Disk Utility or terminal (diskutil list). Ive tried connecting the drive to my 2013 MacBook Air with no success

    Ive tried running Disk Warrior and that cant see the drive either.I find it hard to believe that the 1TB drive failed at the exact point my computer crashed.

    Any ideas how to troubleshoot this?

    SYSTEM:
    OS X 10.10.3
    Mac Mini 5,1 (Mid-2011) 16gb 1333MHz DDR3 RAM 2.3ghz i5, Samsung SSD 830 128gb
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    Some thoughts, may be of use, or may be of no use...

    First, disconnect the 2tb drive and set it aside for now. You don't want it fooling with "the mix".

    Power down, all the way off.
    Disconnect the 1tb drive.
    Reboot the Mac.
    When you get to the finder, Re-connect the 1tb drive.

    Any changes?
    Sometimes, if there is a problem with the disk drivers or directory, the finder may try to repair it before it mounts the drive. Give the finder a few minutes to "digest" the drive after you connect it.

    Still nothing?
    Do you hear the drive "spin up"?

    What kind of drive is the GoFlex?
    Is it a USB connection?
    Or is it something else?

    Is the "core drive" (the drive mechanism itself) removable from the GoFlex enclosure?

    If it is, you might want to take it out and try it in a USB3/SATA "docking station", or try using a USB/SATA "adapter" (dongle).
    The reason for doing this is that while the drive might be ok, it could be a problem with the GoFlex itself.

    You can get docks for about $25 and dongles for around $20 from amazon or other places....
     

Share This Page