External drive not detecting/mountable, formatted in FAT32, need some advice please

Discussion in 'Mac Basics and Help' started by pendledon, Dec 31, 2008.

  1. pendledon macrumors newbie

    Joined:
    Dec 31, 2008
    #1
    Hi guys. I did a search to see if this issue has been addressed before and couldn't find anything specific to my problem.
    I have a LaCie external hard drive (Firewire Porsche 160 GB model). Worked fine and suddenly wouldn't mount to my desktop of a MacBook Pro intel core duo.
    I went through the usual steps of trying to get it to mount but it wouldn't show up in disk utility for any kind of verification or repair. After lots of Googling, I discovered that this particular drive had some power issues so I took the disk out and put it in a new enclosure: A circuity city house brand that's USB2 with external power source.

    It still wouldn't boot and couldn't be detected on my MBP (running latest system software) OR my G5 iMac. The disc is making a bit of a noice but nothing grinding or too loud/dire.
    Today, I went out and bought Disk Warrior 4.1.1 hoping it would detect the drive to repair it or salvage some of the data. THEN, I realize that this external drive (it's a SEAGATE, by the way in a LaCie case) is formatted FAT 32 or FAT32. Which isn't the end of the world but Disk Warrior is no help on drives formatted as such.
    SO...my questions are:

    1. Will this be easier to salvage/repair/detect via a PC with some kind of data recovery software?
    2. The files are small illustrator CLASSIC OS 9.2 files for the most part. All files were from my old G4 Power Mac if that makes any difference.
    3. Is there a data recovery program that might work better than Disk Warrior but work with a mac on an external formatted to FAT32?
    4. Should I try another enclosure?


    I apologize for the blizzard of questions but I wanted to try to give as much info as possible. I really, really need to salvage the data off of this drive. Even if it means that ultimately it has to go to disk savers or other data recovery center. The drive was never damaged physically and always just sat in the same place on my desk.

    If anyone has any suggestions, I would be eternally grateful. And I'm not just saying that...these files are both personal and professional and mean the world to me. This actually WAS the backup drive for an internal drive that failed in my mac. So I'm 2 discs down and the backup isn't responding.
    I believe I've tried every other trick. I've tried to get it booted on my non-intel G5, my intel MBP. I've tried the new USB 2 enclosure, Disk Warrior...I don't know where to go from here but if the PC route might work, I will try to track someone down with a PC and buy a data recovery program to use for it.

    Have a safe and happy new year everyone. Thanks again in advance for any help you can offer.
     
  2. kastenbrust macrumors 68030

    kastenbrust

    Joined:
    Dec 26, 2008
    Location:
    North Korea
    #2
    There could be many reasons for this happening, firstly do other Fat32 formatted memory sticks, hard drives, flash drives etc get recognised by your MAC OS or is it just this particular Hard Drive that wont mount? If other things dont get recognised then its a problem with your computer and not the external hard drive.

    Secondly have you tried connecting the hard drive to another computer, namely a windows computer, if the windows computer doesnt recognise it or mount it then its likely to be that the enclosure is broken, in which case if your comfortable with changing the enclosure you should do so.

    I know of many recovery programs that will get back your lost data for you, however none of them will get a drive refusing to mount in MAC to force mount, which is what you want, and that might not even work anyway if the enclosure is broken. Secondly none of them will get back Illustrator files, so if you cant get the drive to mount in a new enclosure you may be better taking it to your local apple store as the Geniuses have access to drive data recovery software that would normally cost thousands.

    Have a look at this though:

    http://www.subrosasoft.com/OSXSoftware/index.php?main_page=product_info&products_id=1"

    it's worked for me in the past but i can't seem to find the free version i used

    Hope this helps :) :apple:
     
  3. finnschi macrumors 6502

    Joined:
    Dec 30, 2008
    Location:
    Hamburg, Germany
    #3
    Well if it doesen't mount.. data recovery Software is useless! Try to Put it in your Mac as a internal drive, if that doesent work, try a Windoooze Box, XP is actually quiet reliable when it comes to mounting stuff! (just use bootcamp)

    But as you already tried a different enclosure, and a different mac ... don't get your hopes up too much :( I Don't think this is going to work... i think the HD is busted ...
     
  4. i.shaun macrumors 6502a

    i.shaun

    Joined:
    May 1, 2008
    Location:
    Canada
    #4
    Was it on firewire?

    You should have checked if it showed up in system profiler under Firewire. If the firewire shows "unknown device" then it is operational and reading something on the port, but somehow the drive isn't able to communicate or start up.


    Powering off the mac, unplugging everything, including the power cable/battery for 15-20 minutes may fix the firewire issue.




    There's no guarantee of it working considering even USB seems to be ineffective. It may be worth a shot though.


    If it doesn't appear in disk utility, or the system profiler, or a windows PC (if it's FAT32) you might have a failed drive on your hands.
     
  5. pendledon thread starter macrumors newbie

    Joined:
    Dec 31, 2008
    #5
    Thanks for the response, guys. I agree that the situation looks dire. For the most part, this is just a last ditch effort prior to sending it in for professional recovery. I'd much rather spend another $100 trying than to just ship it off to a $2700 estimate.
    And of course, even then, there are no guarantees.

    I really feel like if I would have formatted it as an HFS disk in the beginning that Disk Warrior might be able to recover some items. There are plenty of cases where a drive wouldn't mount or even show up through disk utility where Disk Warrior has been able to diagnose, repair or recover/remount.

    My next step is tracking down a Windows pc and trying bootcamp (thanks for that suggestion). If the windows can't recover some of the files, I'll bite the bullet and ship it off to the professionals.

    Again, I appreciate the suggestions. If anyone else stumbles on here and has a similar experience, I'll probably be trying for the next few days and will still be checking for input.

    Happy New Year guys. May your Macs, whatever the build, be trouble free this year.
     
  6. --- macrumors member

    Joined:
    Nov 1, 2008
    Location:
    Canada
    #6
    I was having the exact same problem, except the enclosure or hard drive would occasionally make a high pitched screeching noise. I switched the enclosure and finally Disk Utility would see the hard drive (Both the drive and Volume) and it stopped screeching. Unfortunately, it was unreadable. I tried Data Rescue 2 (free demo) and it scanned the entire hard drive (took a day and a half) and found no files at all. I think this may be because the external hard drive that I was scanning was FAT32, and not HFS, but it said that it sometimes works with FAT32.

    Anyways, One last thing you might want to try is to put your hard drive in the freezer for an hour or so, then try again ( http://geeksaresexy.blogspot.com/2006/01/freeze-your-hard-drive-to-recover-data.html ). I'm going to try it with mine right away after I try FileSalvage.
     
  7. kastenbrust macrumors 68030

    kastenbrust

    Joined:
    Dec 26, 2008
    Location:
    North Korea
    #7
    Not necessarily, you can get forensic software that will force a drive to mount, the Geniuses sometimes use it behind the bar in Apple stores, i used to use it myself, it depends how clever the guy your talking to is. Its available at home however i cant find a Mac version, and its very expensive, but it would allow you to force mount your drive in Windows, even a Mac formatted drive.
     

Share This Page