External Drive Not Mounting

Discussion in 'macOS' started by cocopelli, Feb 12, 2008.

  1. cocopelli macrumors member

    Joined:
    Sep 5, 2002
    Location:
    Spokane, Wa.
    #1
    I have a Western Digital My Book Essential Edition 500 GB. It is connected via USB 2.0. I use it for storing media and a Time Machine back up. It worked fine for about a week, then it started getting very slow and freezing applications(especially when trying to watch movies off of it). I stored my iTunes library on it, and didn't seem to have as many problems although iTunes was a little slow sometimes. About a week ago, my niece "accidentally" unplugged the drive while it was still mounted. When I plugged it back in, it would not show up in the finder. I can see it in system profiler and disk utility, but not finder. I tried to verify and repair it and it just fails within a few seconds. It says it can not verify or repair the file system. Does anyone have any suggestions? I have searched the forums and all over the internet and found similar problems but no solution. Am I going to have to erase and reformat? If I do, it is not the end of the world as I can get most if not all of the media back from my brothers computer. I was just really hoping to avoid that if at all possible. Also, one last question, if I do end up having to do that, should I have a seperate partition set up for time machine or is it ok to put it on the same partition and the rest of the media? Thanks for any help you can provide.

    Ben
     
  2. sknikos macrumors newbie

    Joined:
    Mar 29, 2008
    #2
    I experience exactly the same problem. Have you find any solution?
    Thank you
     

Share This Page