External Drive not mounting

Discussion in 'Mac Accessories' started by ski2moro, Dec 18, 2008.

  1. ski2moro macrumors 6502

    Joined:
    May 3, 2007
    #1
    Last night, the external drive worked and this morning, no luck. I have all my older backups, my music and movies on it.

    I have a 500 gb USB LaCie that's about 2 years old. The blue light is flashing rapidly like it's trying to read, but it doesn't show up on the desktop.

    The dog got tangled in the usb cable last night and pulled it out at the computer USB port. I got a warning "You have removed a device improperly" or whatever it says. I was not using the external drive at the time the dog moved it. The drive did not tip over. I plugged it back in and went about my business. I don't remember if it mounted or not at that time.

    So now, I can't get it to mount. I tried a different USB cable and the other USB port on the MBP but it still won't mount.

    Any suggestions?
     
  2. mikes63737 macrumors 65816

    Joined:
    Jul 26, 2005
    #2
    Does it show up in disk utility, even though it's not mounted? It would show up in the left sidebar.
     
  3. ski2moro thread starter macrumors 6502

    Joined:
    May 3, 2007
    #3
    might have been the software update

    The drive didn't show anywhere.

    I did some other searching and discovered that it might have had something to do with the software update I did last night. Can't blame the dog for that one.

    I powered down the drive and shut down the computer.

    I started the computer without the drive attached, powered on the drive and then plugged it into the USB. Much to my relief, I had the drive and its contents again.

    I'm going to make a backup of the external drive just in case.

    All's well that ends well.
     

Share This Page