External Drive Not Readable

Discussion in 'Mac Basics and Help' started by EmJB, Jul 6, 2014.

  1. EmJB macrumors newbie

    Joined:
    Jul 6, 2014
    #1
    Hi there

    I've just tried to plug in my external hard drive to my mac (10.6) and it says that it's not readable. When I click on initialize it takes me to my disk utility but I can't repair disk permissions (it's greyed out).

    Does anyone have any ideas what I need to do?!

    Thanks
     

    Attached Files:

  2. chrisrand macrumors member

    Joined:
    Aug 17, 2013
    #2
    Have you tried plugging it in to different USB ports? If so, then this is most likely a sign of drive failure, either mechanically (i.e. it was dropped), physically (bad sectors), or software (lost drive partition map)

    Depending on your level of expertise and willingness to tinker, you can try using a program called TestDisk to see if the partition map can be recovered.

    I'm sure there are better videos than this, but it will give you a general idea of what to do.

    http://www.youtube.com/watch?v=H_EwWNw2lso
     
  3. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #3
    Can you hear the external drive "spin up" when you connect it?

    Is there any way you could take the drive to ANOTHER computer (Mac or PC) and connect it there, to see if you get a similar message?
     
  4. Tumbleweed666 macrumors 68000

    Tumbleweed666

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #4
    And if none of that works, buy another drive and restore from your backup.
     

Share This Page