external drive recognition problem

Discussion in 'Mac Basics and Help' started by gerardg, May 7, 2008.

  1. gerardg macrumors newbie

    Joined:
    May 7, 2008
    #1
    I have an iomega external hard drive which I have been using. All of a sudden my mac can't 'see' it. It CAN see it if I connect with a usb but not with the firewire I have been using.
    I have seen a number of posts which seem to touch on this issue but so far no solutions???
    Can anyone help.
    PLEASE???
     
  2. Kuska macrumors regular

    Kuska

    Joined:
    Sep 14, 2006
    Location:
    Deep in The Weald, England
    #2
    have you recently run the latest iMac EFI Firmware update ?
     
  3. gerardg thread starter macrumors newbie

    Joined:
    May 7, 2008
    #3
    I have the automatic software updates occurring. Would this update the firmware? If not how do I go about getting it updated please>
     
  4. drayman86 macrumors newbie

    Joined:
    Jun 8, 2007
    Location:
    Lansing, Michigan
    #4
    I am also having issues with my iMac recognizing an external drive. I have:

    iMac 5,1 10.4.11, Intel Core 2 Duo 2 GHz, 1GB Memory, PIONEER DVR-112d in a BYTECC ME-525U2FW Aluminum External enclosure connected through Firewire.

    The iMac initially recognized the drive, no problem. Trouble is, when I turn off the drive and then power it back up, the iMac can't recognize it. I was able to solve it initially by powering down the drive, unplugging it from the firewire, reconnecting to firewire, and the powering up the drive again.

    System profiler states all software up to date.

    Any suggestions would be appreciated. Thanks!
     

Share This Page