External Drive - Spotlight keeps indexing.

Discussion in 'macOS' started by Prekesh, Jun 23, 2009.

  1. Prekesh macrumors regular

    Prekesh

    Joined:
    Jan 12, 2009
    #1
    right, i have a HFS formatted 500gb external drive which i use everyday, but today spotlight just keeps indexing it, it has a lot of media on it which i access daily so spotlight is needed to search it.

    how can i fix this?

    i mean its been indexing for a good 2 hours.
     
  2. Signal-11 macrumors 65816

    Signal-11

    Joined:
    Mar 23, 2008
    Location:
    2nd Star to the Right
    #2
    Is Spotlight only indexing the drive or is indexing everything else again as well?

    IOW, if you reboot with nothing connected, does Spotlight reindex?
     
  3. mrchinchilla macrumors 6502

    mrchinchilla

    Joined:
    Mar 6, 2009
    #3
    I have a problem with something similar to this.
    mds when I have my external drive connected, runs at about 170-200+ MB (RSize). And it's quite frustrating, I've tried a lot, from changing permissions of the hidden Spotlight folders in the root of the drive, to playing with privacy settings, and it always just ends up reindexing which takes about 3-4 hours and makes my computer run HOT and use 100%+ CPU.
     
  4. Signal-11 macrumors 65816

    Signal-11

    Joined:
    Mar 23, 2008
    Location:
    2nd Star to the Right
    #4
    Similar discussion if not having a Spotlight index will work for you:

    http://forums.macrumors.com/showthread.php?t=309194

    If you need Spotlight, it might be a corrupted index file, in which case you might consider deleting it and letting it reindex.
     
  5. mrchinchilla macrumors 6502

    mrchinchilla

    Joined:
    Mar 6, 2009
    #5
    I've tried all of that already. And every time I delete it, or add the metadata_never_index etc. It just indexes again and then I'm back where I started, I just hope SL will fix it, or even 10.5.8.
     
  6. Signal-11 macrumors 65816

    Signal-11

    Joined:
    Mar 23, 2008
    Location:
    2nd Star to the Right
    #6
    Are you sure that the file is named ".metadata_never_index" and not "metadata_never_index"?
     
  7. mrchinchilla macrumors 6502

    mrchinchilla

    Joined:
    Mar 6, 2009
    #7
    Yes it was a hidden file, in my previous post I didn't go into any detail or make sense as I was eating ice cream. :cool:
     
  8. Signal-11 macrumors 65816

    Signal-11

    Joined:
    Mar 23, 2008
    Location:
    2nd Star to the Right
    #8
    Sounds to me like you need to completely start over. Delete your Spotlight index, then have it re-index everything. Or have you tried that already as well?
     
  9. mrchinchilla macrumors 6502

    mrchinchilla

    Joined:
    Mar 6, 2009
    #9
    Already tried that..
    I have noticed MDS increases in RSIZE whenever Time Machine is backing up, it goes up to about 200MB and stays at about 170~.
    Isn't it supposed to return to about 20MB?
     
  10. Edward Tippins macrumors newbie

    Joined:
    Jun 26, 2009
    #10
    How do I stop Spotlight from indexing

    Hello,

    I'm a newbie to the Mac World, but wanted to give it a try. I have a MacBook Pro notebook (Leopard) and am very impressed with what I see.
    My problem: I've been transferring files from my USB's to the hard drive with some success, but suddenly, Spotlight started indexing the USB drive. I don't know how to stop it or why it's happening. Any suggestions would be appreciated. Thanks.
     
  11. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #11
    @ Edward: Navigate to System Preferences, then Spotlight (in the first row), and finally to the Privacy tab. Drag and drop the external hard drive icon from the desktop to the white area in the Privacy tab. The drive should stop indexing.
     

Share This Page