External Drive - USB Connection Recognized, FireWire Connection Not Recognized

Discussion in 'Mac Accessories' started by davidosus, Jan 28, 2009.

  1. davidosus macrumors newbie

    Joined:
    Aug 26, 2008
    #1
    I consider myself very good at all things Mac. But this one has me stumped.

    I've just arrived home with a WD My Book Home Edition 1TB external drive. Formatted for Windows it mounted correctly via FireWire and USB.

    First things first: I formatted it for the Mac... Mac OS Extended (Journaled), two GUID partition tables. So far so good. Each partition is recognized, each mounts like it should.

    Time Machine then backed up my Intel iMac... again, everything's normal. No odd or unusual behavior.

    Here's where things get strange.

    For whatever reason I formatted the drive via USB. But my intention hereafter is to connect via FireWire... I need each USB port for peripherals.

    But the drive isn't recognized through FireWire. I'm asked if I want to initialize it. When reconnected through USB the drive mounts again.

    What's going on? Why is the drive recognized when connected via USB but not when connected via FireWire?
     
  2. pach22 macrumors newbie

    Joined:
    Jan 31, 2009
    #2
    WD My Book Drive Prob Solved

    Try placing the WD power supply away from the drive (a few feet). I was just up all night and tried everything (cable replacement, restarts, tapping, prayer, forums, etc.).
    Hope it works.
     
  3. ZMacintosh macrumors 6502a

    ZMacintosh

    Joined:
    Nov 13, 2008
    #3
    hm, have you done a power cycle of the drive and the computer?

    Try a PRAM Reset and an SMC Reset to further test if the ports might have acted quirky.

    when doing the PRAM & SMC resets id recommend unplugging the harddrive form the computer.

    PRAM Reset:
    COMMAND OPTION P R keys all at once immediately following the start chime and before the grey screen appears.

    SMC Reset:
    iMac/MacMini



    MacPro



    MacBook/MacBook Pro/MacBook Air:


    http://support.apple.com/kb/HT1894



    ---

    Or if the reset doesnt work. try formatting it blank under USB disconnect, restart and plug in with firewire and see if it recognizes then....if so format using firewire and try both connections. could be a possible bad Firewire cable, and unstable port on the imac or the enclosure.

    ive had some touchy ports on my external enclosure before aswell.
     
  4. WishingDigiJosh macrumors newbie

    Joined:
    Jan 26, 2009
    #4
    if i'm understanding correctly... your computer still sees it when it's connected via FireWire, but is asking you to initialize the drive as if it were new out of the box?

    that's odd behavior, let us know if the PRAM and SMC resets help.
     

Share This Page