External Drive Won't Stop Spinning?

Discussion in 'OS X Yosemite (10.10)' started by Autokon, Oct 18, 2014.

  1. Autokon macrumors 6502

    Autokon

    Joined:
    Jan 21, 2008
    Location:
    CA
    #1
    Hi guys!

    Ran the Yosemite Beta and GM and never had this issue. Well, I did a nice and clean install the other day for Yosemite and am now having a weird issues with my external hard drive (WD My Book). I can constantly hear it being accessed (spinning) when absolutely nothing is going on. Usually when no access is occurring, like normal, it sleeps until being accessed again. The only way to silence the bloody thing is to unmount it. I've went drastic and even formatted it, still, the issue persists.

    Any thoughts on this? Advice or tips to try to make this thing sleep when not in use?

    Thanks all!
     
  2. Pyrone89 macrumors member

    Joined:
    Oct 18, 2014
    #2
    I had the same after installing Mavericks, it never got solved. I am used to the noise now. Mine is a FireWire Lacie.
     
  3. Autokon thread starter macrumors 6502

    Autokon

    Joined:
    Jan 21, 2008
    Location:
    CA
    #3
    Ugh, how annoying.

    How can I tell if its simply my external drive just indexing? I'm not seeing a visual indicator anymore for indexing. I'm wondering if its doing that since its a fresh install. It has nearly 2TB of data on it.
     
  4. mzd macrumors 6502a

    Joined:
    Jul 25, 2005
    Location:
    Wisconsin
    #4
    sigh. i can't believe this hasn't been fixed yet. Apple has had an entire year. none of the Mavericks updates took care of it, and now it looks like Yosemite hasn't fixed it yet either. unbelievable. :mad:
     
  5. PhillyGuy72 macrumors 6502a

    PhillyGuy72

    Joined:
    Sep 13, 2014
    Location:
    Philadelphia, PA USA
    #5
    This happened to me THURSDAY night (day before OS 10.10). Out of nowhere for the first time, I was still on Mavericks.

    I put it to sleep, went to bed. All of a sudden my Mac wakes up..I hit sleep, it woke up. Anyway, Spotlight was showing it was Indexing my one HDD..no idea why. Anyway, I somehow was able to stop it and just shut the computer off. Lot of churning of the HDDs

    It ran the indexing yesterday morning, again after I installed Yosemite, only took about 5 minutes though. Haven't had a problem since.

    My biggest issue right now is how much RAM this 10.10 is sucking up..whoa! I run Photoshop a lot, it was ok in Mavericks. Now, it's extremely sluggish. :confused:
     
  6. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #6
    2TB will probably take a few days to index Spotlight....
     
  7. poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #7
    Put the volumes in privacy list for spotlight so it won't index
     
  8. R2D2WD macrumors newbie

    R2D2WD

    Joined:
    Sep 23, 2014
    #8
    Hi there,

    Could you tell me your My Book model number? It is rather unusual a drive to spin without any particular reason and usually this is not a good sign. I would advise you to do a HDD check just to be safe. In your case, I believe it is a matter of a software issue. Make sure that no software is doing some scans/searches/backups in background mode. I have heard of similar issues coming from Spotlight, so I recommend you to change it's settings. I would check my external's behavior on another PC.

    http://www.tekrevue.com/tip/three-ways-to-prevent-spotlight-from-indexing-items-on-your-mac/ - check this article about Spotlight

    Hope this helps
     
  9. Tigerman82 macrumors regular

    Joined:
    Jul 27, 2010
    #9
    I recently bought WD My Passport Studio 1TB FW800 external HDD for backup and added storage purposes. I'm using a mid-2010 iMac. I'm currently using it with Yosemite but I also tested it with Mavericks, and the drive behaves the same way in both operating systems. I'm not using Time Machine for backup so there isn't any scheduled processes going on. I do use SuperDuper! but only the free version (create clones manually).

    Yeah, the darned thing won't stop spinning even though I'm not using it in any way. It does stop spinning when I put my Mac to sleep or shut it down, but shouldn't it stop spinning when it's idle. The noise is annoying especially since I was used to the silence offered by the SSD drive inside my Mac. I initially installed the WD Turbo drivers for Mavericks (which do make a slight but noticeable difference in speed) but then removed them to make sure they were not creating the problem. I also tested the Sleep Timer function of WD Drive Utilities but it didn't help. I also made sure that I had ticked the option for Mac to put drives to sleep when possible.

    Luckily I came across two apps: Jettison and Mountain. They both offer unmount and remount functions from the Menu bar. I'm currently testing the trial version of Jettison and it does work. I unmount the WD drive, prevent it from remounting after wake-up, and then remount whenever I need to use the drive. The WD drive is silent and only a bright light is slowly flashing. These are paid apps (actually about the same price) and I will have to test Mountain as well, before I make a decision.
     
  10. northernlights101 macrumors newbie

    Joined:
    Jan 2, 2017
    #10

    I have been plagued with this issue for TWO YEARS and lost a valuable external drive because of the constant spinning. It was my Monster ecogreen power strip that was power cycling it. It detects when the computer stops drawing a certain amount of power and then shuts down the peripherals attached which included my drive. I think the minimum current draw was just borderline to cause it to cycle on and off. Since its been gone, NO MORE ISSUES.
     
  11. DiegogDiegog macrumors newbie

    DiegogDiegog

    Joined:
    May 24, 2017
    Location:
    Miami Beach
    #11
    THANK YOU!
    SOLVED AS WELL!
    After a whole year of troubleshooting, I replaced a regular power strip instead of the Tricklestar I was using.

    I can finally move on now.
     

Share This Page