External Drive Works in One Dock But Not Another

Discussion in 'Mac Accessories' started by ces62853, Feb 8, 2016.

  1. ces62853 macrumors newbie

    Joined:
    Feb 8, 2016
    #1
    Hi All,

    I've got 2 external drives in a dual bay dock. Both were working fine up until yesterday when I was copying files from my computer to one of the external drives and I got an error (about 80gb in) that it couldn't complete the transfer. It continued to give me error messages every time I tried to reinitiate the transfer, so eventually I decided to unmount and try again. But then it wouldn't eject either of the drives. So I force ejected them. And after that they no longer mounted at all.

    Disk 1 continued to be recognized by Disk Utility, which told me it was dead and couldn't be repaired, so I DiskWarriored it and it's fine. It mounts just fine from the dual bay dock.

    Disk 2, however, wasn't showing up at all in Disk Utility, so I thought maybe the drive really was gone or something had happened to that bay of the dock. I tried it in the other bay and still nothing. I tried it on its own in the dock and still nothing. So then I put it into another dock that I have and the computer all of a sudden recognized it. I DiskWarriored it too and now it works fine from the second dock. But when I put it back in my dual bay dock, the computer still doesn't recognize it.

    One last thing. When both drives are in the dock (and it's showing Disk 1 in the Finder), if I remove Disk 2, it doesn't like that and automatically unmounts Disk 1.

    Does anyone know what's going on or have a fix? I normally wouldn't care about having to use multiple docks except that the dual bay dock is convenient because (a) I can connect it to my wireless router and have 2 wireless drives and (b) it's a USB 3.0 connection where my alternate dock is only 2.0.

    Any help would be greatly appreciated! Thanks!
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    I, too, have run into problems when connecting external USB docks, drives, and dongles.

    Some of them have been like yours -- drives that dismount when another is mounted, or won't mount at all.

    I'm going to -guess- that some of these irregularities are due to discrepancies between the USB controller chips used in various docks and dongle adapters (enclosures, too).

    It could also be a problem with disk drivers which [I assume] get written to a drive during initialization, and can become corrupted later on.

    Back in the old days of SCSI and Apple "HDSC setup" utility, there was an option to "update the drivers" on a connected disk. I'm -guessing- that this command wrote a clean set of disk drivers to the drive.
    But there seems to be no such equivalent command in USB. I'm not sure if Disk Utility's "Repair disk" command will update a disk's drivers.
    Perhaps (with USB) the only way to put a "fresh and clean" set of drivers onto a disk is to re-initialize it.

    I would suggest that you re-initialize "Disk 2" in the dual dock.
    Of course, anything on it that you wish to save, you'll have to copy elsewhere first.
    No promises that this will work...
     

Share This Page