External drives not mounting nor ejecting consistently

Discussion in 'OS X El Capitan (10.11)' started by ChrisDx, Feb 10, 2016.

  1. ChrisDx macrumors member

    Joined:
    May 2, 2007
    #1
    Hi all;

    I have been having issues with consistently mounting and ejecting external drives since installing MacOS 10.11.3. Sometimes they would mount after restart, sometimes not. When they do mount, I may need to go into the Activity Monitor and deselect mdworker.

    I thought I had resolved the issue by getting a powered USB3 hub, but that is also not consistently working.

    I have three WD drives with USB connections. I also have a LaCie external with a FireWire connection and that works consistently.

    The issue presents on my 27" iMac but not on my MBPro nor MBAir; all running 10.11.3.

    Any ideas?
     
  2. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #2
    It would probably help you better if your question was asked in the OS X El Capitan forum. This is the iOS 9 forum.
     
  3. daghstdrummer macrumors member

    Joined:
    Jul 2, 2012
    Location:
    Manhattan, NY
    #3
    Try disabling spotlight for the externals and see if that works... Worked for me.
     
  4. psik macrumors 6502

    Joined:
    Aug 21, 2007
    #4
    LOL? Sarcasm.


    Yes please let us know if the proposed semi-solution ( I say semi because what if some people want their disks to be spotlight indexes, and i am surprised apple doesn't give a damn about this bug).
     
  5. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #5
    It was in the iOS 9 forum before it got moved.
     
  6. ChrisDx thread starter macrumors member

    Joined:
    May 2, 2007
    #6
    Hi all;

    Sorry If I started this thread in the wring forum.

    Here is an update. I had been using an USB2 un-powered hub for years with this iMac with no issue. When the mount/eject issues presented, I purchased the USB3 powered hub which seemed to have resolved the issues. But that appeared to be short lived.

    At the back of my iMac, are 4 USB ports. I tried various combinations including connecting the drives directly into each of the four ports. The drives worked on all the ports except one. That one also does not work with my keyboard/mouse connection. I'm not sure if that one port was the one in which I had previously connected the powered USB3 hub. I had recently copied 2.7 TB of data from one external to another (took 2 days to transfer). Might that have "burned out" the port?

    I now have the USB3 hub connected to another port and that seems to be working (for the most part but that is subject for another thread).

    Chris
     
  7. ChrisDx thread starter macrumors member

    Joined:
    May 2, 2007
    #7
    OK it seems like an USB port issue. I'll start another thread on this.
     
  8. Gochugogi macrumors regular

    Gochugogi

    Joined:
    Oct 27, 2013
    Location:
    Sandwich Isles
    #8
    10.11x is really picky about USB hubs. I went through 5 different hubs before I found something that worked, suffering random dropped drives and drives not mounting at startup. The devices work fine plugged directly into my Mini i7 but with over a dozen USB devices four ports ain't cutting it. The only hubs that worked consistently for me is the hub build into my Cinema Display and, strangely enough, an Inateck 2.5" drive enclosure with built-in 3 Port USB 3.0 Hub. So I have to keep devices offline until needed but it's great to have a stable and dependable Mac again...
     
  9. MNR macrumors regular

    Joined:
    Nov 4, 2014
    #9
    Well, I had a similar issue with a WD passport ultra external hard drive and my macbook pro retina late 2013 after El Capitan update. I was really annoyed because the hard drive was detected and mounted before the update and was still detected and mounted on my old iMac with Yosemite. Because of all the stories with El Capitan and HD not mounting correctly, I was convinced this was the issue and even believed tehre was a defect with my usb ports on my macbook pro. Well, it turns I realized I had another "old" WD passport filled with data and that one was detected on my macbook pro, so I just switched the cable and it worked again! I ordered a brand new usb 3.0 for the passport ultar and now I have no more issues ... Perhaps you should take a look at your cables, or plug them directly in the usb port too.
     
  10. ChrisDx thread starter macrumors member

    Joined:
    May 2, 2007
    #10
    Hi all;

    Here is an update on my particular situation. It appears that my problem was that I had a "dead" USB port. Resetting the SMC in the normal fashion did not resolve the issue since a different port went dead after each reset. Apparently, the SMC reset is heat sensitive. So, then I left the Mac unplugged for a couple of hours to cool down before trying it again. Hallelujah, it worked!

    Chris
     

Share This Page