External drives won't eject

Discussion in 'OS X El Capitan (10.11)' started by ChrisDx, Jan 5, 2016.

  1. ChrisDx macrumors member

    Joined:
    May 2, 2007
    #1
    External Hard Drives (WDs) won't eject since upgrade to El Capitan (10.11.2). It happens on my iMac and laptops. Pop up says other programs may be using the hard drive but that is not the case. I need to restart, with external still mounted; then I am able to eject. Bit of a pain.
     
  2. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #2
    I sometimes have issues with drives not ejecting. A couple of reasons, probably not related to yours, are:

    1) I watch a video in QuickTime Player, close the video. QuickTime Player shows as not being active in the dock. Drive won't eject. I "open" QuickTime Player and quit. Then I can eject.

    2) I use terminal to view/work on a disk. I go back to my home directory. Sometimes the drive won't eject. I usually have close the tab or window in terminal to have the drive eject. This was not a problem before Yosemite.

    You may have programs running (anti-malware, whatever) in the background that use the disk but don't release it or that OSX doesn't recognize as being released.

    Are your drives GUID HFS+ (maybe there's an issue with non HFS+ drives in El Capitan).

    Do you have software that came with your drives that you use? There have been issues with some of the WD software and El Capitan.

    Did this issue start in when you updated (from a previous El Capitan version) or when you upgraded (from Yosemite or earlier OSX)?
     
  3. Riwam macrumors 6502a

    Riwam

    Joined:
    Jan 7, 2014
    Location:
    Basel, Switzerland
    #3
    ********
    I don't believe that my little knowledge is enough to help another user.
    Still a few words.
    "Etrecheck" is usually suggested to run and see the result. It cannot harm.
    The 3 free tools I particularly like and use, made by Titanium Software:
    "Onyx", "Maintenance" and "Deeper".
    Onyx cannot harm and maybe helps... who knows?
    Good luck.
    Ed
     
  4. ChrisDx thread starter macrumors member

    Joined:
    May 2, 2007
    #4
    Actually, mounting and ejecting is quite hit and miss. I thought I had resolved the mounting issue in another discussion thread but apparently not so.

    I work with an iMac and two laptops on a regular basis. I have 4 external HDs (a LaCie and three WDs). With the exception of one of the WDs (which I got just days ago, after installing MacOS 10.11.2), the three drives worked fine before upgrading from Yosemite last week. The new drive is formatted GUID HFS+.

    The workaround is restarting the computer with the drive plugged-in to mount and eject. Quite a pain.
     
  5. Kornelis macrumors member

    Kornelis

    Joined:
    Dec 4, 2010
    Location:
    Amsterdam, NL
    #5
    Yes, I had the same thing happen to me. My external USB backup drive didn't want to eject and I got the message you mentioned.

    I finally managed to get it ejected by disabling Spotlight and then eject the drive.
    To disable Spotlight:
    sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

    After the drive is ejected you can enable Spotlight again with:
    sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
     
  6. getrealbro macrumors regular

    Joined:
    Sep 25, 2015
    #6
    When you get the drive-can’t-be-ejected notice, it is often worth closing all the apps that have no files open. There are a handful of applications that “hang on” to a drive, even after all the files on that drive/partition are closed. TextEdit is one of these bad boys.

    But the worst offender of all is Spotlight. Once Spotlight starts indexing an external drive/partition it is very difficult to pry that drive/partition loose from its clutches. You can tell if spotlight is the culprit by trying to add the drive/partition to Spotlight’s Privacy panel. If a drive/partition is currently being indexed, Spotlight will refuse to let you add that drive/partition. Your only choices are to disable Spotlight (as Kornelis described) or be patient. I make that choice on the size of the drive and the complexity of the file structure.

    —GetRealBro
     
  7. ChrisDx thread starter macrumors member

    Joined:
    May 2, 2007
    #7
    Yes I have tried closing all the launched apps. That didn't seem to work. I'm not sure how to turn off Spotlight, can you explain?
     
  8. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #8
    You need to open the Terminal application (it's in the Utilities folder in the Applications folder) and enter the lines in post #5 above at the prompt and then press the Enter key. It will ask you for your password and it should allow you to run the command if you've been set up as an Admin.

    Once you disable Spotlight, you can add your drive to the list of items not to index. In System Preferences, select "Spotlight" on the first line, press the "Privacy" tab, press the "+" button towards the bottom and select the external drive. From there you can re-enable Spotlight and see if you can eject the drive. If you can't then there's likely something else holding on to the drive.
     
  9. hwojtek macrumors 65816

    hwojtek

    Joined:
    Jan 26, 2008
    Location:
    A small rural village in western Poland
    #9
    Much easier: open Activity Monitor, scroll till you find "mdworker" process, force quit it, eject disks. Don't worry for the mdworker (Spotlights worker process), it will relaunch by itself.

    This is a known bug in El Capitan.
     
  10. ChrisDx thread starter macrumors member

    Joined:
    May 2, 2007
    #10
    In Activity Monitor, there are five tabs across the top. Which one should I use?

    The listings under each tab are not alphabetically organized and seem to constantly re-positioning so it is difficult to find and select a listing.

    Once selected, how do I force quit?
     
  11. hwojtek, Jan 6, 2016
    Last edited: Jan 6, 2016

    hwojtek macrumors 65816

    hwojtek

    Joined:
    Jan 26, 2008
    Location:
    A small rural village in western Poland
    #11
    Any.

    As you've probably already figured out, they show all the running processes in different contexts. CPU usage (on the tab marked "CPU") energy usage ("Energy"), disk usage ("Disk") etc. I believe this is self-explaining enough?

    Have you tried clicking the "App name" header in order to sort apps alphabetically? Hint: all OS X apps sort their data by clicking the header. Like Finder for example.
    Or maybe you tried using the process search that is built into Activity Monitor? Right side top. There is a loupe. And the word "Search".

    Did you see the FIRST button on the left? The one with the "X" sign? Guess what happens to this inactive button when you select a process from the list.
     
  12. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #12
    There's a free menu bar app that can be useful for mounting/unmounting volumes.

    It's named "Semulov".

    Worth a try...
     
  13. jhencken macrumors newbie

    Joined:
    Jul 17, 2011
    Location:
    Watertown, MA
    #13
    I find that ForceQuitting mdworker doesn't help. It pops right back up on its own.
    --- Post Merged, Jul 2, 2017 ---
    It's a sweet little program, but it doesn't solve the problem at hand, which is that there are drives that don't want to unmount unless Forced.
     
  14. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #14
    "...it doesn't solve the problem at hand, which is that there are drives that don't want to unmount unless Forced."

    When I encounter a drive that won't eject unless "force eject" is required... well... I just use it. And don't worry about it.

    Drive... be gone!

    Works for me.
     

Share This Page