External DVD Burners not working properly - Need urgent help :(

Discussion in 'Mac Accessories' started by Cattywampus_, Mar 13, 2007.

  1. Cattywampus_ macrumors 6502a

    Apr 19, 2006
    I have a Macbook Pro - first revision.

    About 5 months ago I bought an external DVD writer to use as the 4x drive in my MBP is far too slow. I was excited about being able to burn a DVD in around 4minutes! My choice of burning software has always been Toast.

    So I buy an LG GSA-E10L External USB2.0 16xDVD±RW/RAM. I connect it to USB2, I bought some Datawrite 16x DVD-R discs and I was all set. But when I came to burn DVD's, it always took about 7-8 minutes to burn - which is about 8x. I thought I had some dodgey discs. So I went and bought some Verbatim 16x discs. Same thing! When Toast 8 came out I thought that might stop the problem, but it didnt.

    I thought I would try another piece of burning software. So I got hold of the Disco beta. Yay, I was able to burn a full DVD in about 5minutes. So I thought it *must* be Toast. I posted on the Toast forum asking - and people were suggesting that I try a Lacie firewire drive. They are £100 them drives and I didnt want to spend that much. So instead, I ordered a Freecom firewire drive.

    When it arrived, I was sure this would end my problems. But, it has lead to even more. The drive would not burn when connected to firewire. It would error all the time and the system would lock. I thought it was a crap drive, and after telling people on the Roxio forum i had bought one, they said waste of money. I sent the drive back and plumped for the Lacie USB2 and Firewire D2 drive which claims it can write DVD-R/+R at 16x.

    It arrived today and boy my problems feel alot worse. Connecting the drive via USB2, I am still unable to write at 16x in Toast. In Disco it seems to be ok - so far USB2 performance seems to mirror that of the LG.

    Firewire is just a joke. In Toast, the drive errors giving me this message :

    The drive reported an error :
    Sense Code = 0x04

    Either that, or it sits there preparing the disc and not actually doing anything. I have to power the drive down and reboot to get any use out of it again. Using Disco, that is even worse. I tell it to start burning - it "prepares" the disc, it flashes up writing, and then instantly says Finishing and just sits tehre. I have to disconnect the drive again to get any use. I get similar results when trying to burn through Finder, and through Disk Utily - also using Burn.app gives the same results.

    The drive in the Lacie is a Tsstcorp CD/DVFW SH-S162L (Samsung).

    I have tried EVERYTHING I can think of to get it working and nothing seems to get it working.

    I have all updates (10.4.9), I have wiped the system and reinstalled MacOSX, I have connected the drive off the back of a Firewire 800 drive that connects to a ExpressCard34 FW800 card, I tried the DVD+R disc that came with the drive, I have updated the firmware o fthe drive from Lacies website. The FW400 port on the MBP is not defective as I ran a hard drive through it to be sure, and my MiniDV camcorder works though it.

    I am banging my head against a brick wall here. I mean, they sell the drive on the Apple website for gods sake! . I didnt buy it from there, but still!

    Any help would be very appreciative
  2. Super Macho Man macrumors 6502a

    Super Macho Man

    Jul 24, 2006
    Hollywood, CA
    That's a bummer. I used to have an LG GSA-5163D connected to a TiBook via Firewire. I used Toast 6 & 7 with it and 1 out of every 3 discs was a coaster, with Toast hanging after "Writing Lead-In..." I don't know if it's because I had 6 devices on the Firewire bus or because that's just the way cheap-ass computer components manufactured fly-by-night in China tend to be.

    Now I have the same drive connected to a new iMac via USB2, and it works fine. I don't know if it's doing 16x, as I always burn at the slowest speed possible (4x). I don't have any 16x media handy to test. But no behavioral weirdness at least.

    Here are a couple links that might be of use, if you haven't seen them yet:

    What I would do is search that drive database for a known good drive and pop it into an enclosure with an Oxford bridge chip such as the 911. Oxfords are the most tried and tested of all bridge chips w/ Macs and outperform all others by far. One of the problems with these external drives like the Lacies & Freecoms (Freewho?) is that you can never be sure what exactly you are getting, and the makers have no incentive not to put a piece of crap Genesys or Prolific bridge chip in there just because it's cheaper to source. It really does make a difference.
  3. Fearless Leader macrumors 68020

    Mar 21, 2006
    wow you've stumped me. I ran over the data rates and USB2.0 is sufficient in theory and from what i've sen in practice to get get 16x speed. we are talking single layer disks right?

    What might be happening is that the USB speed might make the computer think it cant get enough data to run at 16x and prevents it from happening.

    Is it possible to run at a middle ground between 8 and 16?
  4. Cattywampus_ thread starter macrumors 6502a

    Apr 19, 2006
    This is my third external drive though - I dont wanna be buying more drives and external components etc. I want the drives I bought to work. I mean its a Lacie, Apple sell them. Surely it has to work?

Share This Page